OSMC Samba woes

OK I have installed samba via the app store and can see my pi from my Windows machine but it asks for username and password which I know is osmc and osmc but it won’t let me access the devices folder where my external hard drive is connected. So I have 2 issues, 1. I would like to be rid of the username and password and 2. How do I get my windows machine to access the external drive attached to my pi?

Thanks in advance.

I have a model B pi with adequate power. Everything else works as it should.

The username and password should not be an issue - just tick the box that says remember the password the first time you connect from windows and it will remember this in future.

For the external drive, what file system is it formatted with, and what error do you get trying to access it ?

The hard drive is formatted as ntfs. I would like to be rid of the username and password as I use some programs on my windows pc to scan for new episodes etc…
Do I need to add the external hard drive to the fstab? It is auto mounted and works fine from the pi eg. I can watch movies etc I just cannot access it via my windows pc. I can however access the external hard drive via my phone with es explorer.

I would suggest you map the share to a network drive in Windows via Explorer. Then you can reference it as a drive without having to use the SMB share each time

1 Like

I would do that but as I stated from my windows machine I cannot access my external drive connected to the pi. Never had these issues with raspbmc.

You are still yet to describe the error that you’re seeing. You’re basically just saying “it doesn’t work”, which helps nobody to solve the problem.

Do you see a media share ?

Do you see the name of the connected drive as a folder in that share ? What happens when you try to open it ? Do you get a specific error, does it time out ?

Is the folder just empty ? Do you see files but you can’t open them ? Have you tried to connect from a different machine ?

I know i still manually set up an SMB account and password and have no problems. Is this required or is the default user ficen access to the shares? Could be as simple as no SMS user account set up.

When you install via the App Store (osmc:osmc) is granted access to shares.


1 Like

Good job, i can take an extra line out of my build process. I was still doing it the old Raspbmc way.

Ok ill try to be more precise.

When i open up network on my windows pc i see the icon for OSMC just like you would any other network device. Whe i double click it i get this
All i would like to be able to do is click on the OSMC icon to access my Media to transfer new content or delete old content without the need for a username or password.
Now in case you ask, yes my network is configured correctly as i can ssh into my pi
as seen above.
I am using the default smb.conf that comes installed with samba from the app store.
If i type in the address to my pi in the address bar i get prompted for a username and password (osmc:osmc) which i wish to remove. The reason i left this section for last is because previously i could access my pi (Raspbmc) from the network icon but now i cannot and that way would be preferred.

I hope this helps clarify.

With OSMC RC i just added

map to guest = Bad Password

in the global section of my /etc/samba/smb.conf

and I dont get asked for a password

Incidentally I just tried to check this using my share to the root in OSMC but to my surprise the update to RC2 has completely overwritten my smb.conf file without saving a backup !!

Oddly enough its now messed up permissions so I cant write to this share ho hum
sorted the permisions out with
guest = root


That SSH login screen doesn’t prove anything, as SAMBA has its own way of dealing with passwords. You might need to post your /etc/samba/smb.conf, in case there is a readily spotted problem there.
Just in case there is a problem with the clicking on icon to access, can you see if accessing by use of \\IPaddress in the explorer path field exhibits the same behaviour.

I tried that to no avail.

I’m using the default smb.conf as stated in my previous post.

A couple of questions -

  1. Have you tried connecting to \\osmc\osmc instead of just \\osmc ? Depending on the security settings of your windows install the second may not work but the first should.

  2. Have you changed your password to osmc and if so are you expecting that new password to work for samba as well ? The samba password must be changed separately to the ssh password using smbpasswd. Both passwords start out as osmc, but they don’t track each other.

1 Like

I have tried both of those yes. No I have not changed any passwords.


when I installed samba from the store I also could not connect from my Windows machine. I did not think about it a lot and just set a new password for the osmc samba user (smbpasswd -a osmc). After that I could connect and browse all shares.

I’ll try changing the password for samba tomorrow as I switched cards and am now back on raspbmc to update my media as I have it configured with no password as I prefer it that way to access from all my home devices.

Question? Why can I not use the smb.conf from raspbmc with osmc? Obviously changing pi to osmc which I did but it was of no use.

Could you try going back to the smb.conf that we ship with OSMC and add this one line in the [Global] section ?

map to guest = bad user

You can get the original file from here if you didn’t make a backup:


After that reboot both OSMC and your Windows PC - see if that allows you to browse to \\osmc (or via Network) and see the share list, which should be devices and osmc. When you actually try to enter one of the share it should still prompt you for a username and password however. (osmc/osmc)

I wonder: have you tried changing the ownership of the external drive on the RPi to your own account? Because if you are able to see the contents of the RPi’s SSD card on your Windows PC but not the external drive, that could be it.

In hope,