OSMC Script Errors

I’m running OSMC on a RPi 1, and getting script errors. I need some help to fix this.

I’m completely new to this, and the terminology isn’t there for me, so I’ll just write what I know.

I started using OSMC 2 weeks ago. After adding several video add-ons, things worked fine. I streamed from several sources. Then, one evening I started getting script errors on everything: PBS, NASA, etc. I reloaded the software on the SD card, but no luck. The version is the latest (not a release candidate), and I run the streaming through a high speed internet service connected by wire and not WIFI.

I read something about Kodi and the add-on. Did I unknowingly add that to cause the problem? I can’t recall.

Should I be using some other software on a laptop to stream to a display? Would that be more reliable or probvide more sources?



First, I already wrote the info.

Please re-read your original post, and the reply to it by ActionA.
You will find that there is a whole lot of missing information, on which a sensible might be made.

I tried OpenELEC on the same hardware and got the same problem. The software update worked, installing video add-ons worked, but streaming the video caused a “script failed” error each time.

For those who need to know: This is Pi B 1 and it has a mouse and keyboard connected through a powered hub. Since the identical hardware was used before and after the trouble started,. Its unlikely that the problem lies in the hardware, and since both OSMC and OpenELEC exhibit the same problem, I can only conclude that the problem started outside my home, or has to do with software common to the two products - perhaps the updated add-ons which are PBSThinkTV and TVOntario in the case of OpebELEC only. For OSMC, more add-ons were installed. and then exibited the same error.

Frankly, given the systems, I’m surprised that many others aren’t reporting similar errors.