OSMC Settings usb_max_current wrong format

Hi there

I am trying the Alpha 4 release and while trying to get an external 2.5" usb drive to power up I have found a bug in the OSMC settings app.

The app has a setting for usb_max_current=1 but activating it does not work. However if I manually add max_usb_current=1 to the file the drive works as expected.

It looks like somehow the max & usb bits of the setting have ended up around the wrong way in the app.

As this looks to just be a typo, hopefully it can be fixed for the next release.

This has already been fixed and is scheduled for the next build


both methods are not working for me!

Pardon ?

Can you please explain what you mean by “not working”. max_usb_current=1 set via the Pi Config gui was fixed a couple of months ago at least - you are replying to a 5 month old post. :wink:

Thanks, I know that the post is old but I have the problem. Did try both methods. The ac adapter is 5V 2 amps. The external hdd is the ‘western digital my ultra passport’. The raspberry pi 2. The external hdd starts clicking and the osmc freezes.

Sounds like your 5v 2a power supply is still insufficient. Not uncommon.

Just because you have set max_usb_current=1 doesn’t mean that your Pi is guaranteed to power all external 2.5" hard drives - many drives simply draw too much power regardless of this setting.

Also, just because your power adaptor may state 5v 2 amp on the label doesn’t mean that it maintains 5 volts under a load of 2 amps - a large percentage of micro USB adaptors do not as they are only designed as chargers not power supplies. So unless your adaptor is specifically made for the Raspberry Pi, there is no guarantee that the voltage is staying at 5v with the extra load of the drive.

You could try a different power adaptor but if that doesn’t work your only choice is to power the hard drive with it’s own power adaptor.

I am pretty sure that the adapter is suitable for raspberry pi.