OSMC / SMB share : files missing

Hello there.

I read lots of stuff here about SMB share and various problems.
I took the time to try all the solutions provided by various member, but nothing seem to work.
So I finally create an account to post my problem.
I hope someone could help me.

So, here we go.
The problem I have with SMB is that I can add the SMB share, no problem, with that.
When I try to add video or music source from my SMB, the folder start syncing but then it stops without reason. So lots of files are missing, if I enter the source I added (i.e : videos) , the folder can be empty, or have some title in it, if I exit the forlder and re-enter it again, some title could have disappeared, or the folder can be empty.
example :
I have shared a folder with 49 items : the new dragon ball super anime.
In the video section, I Add a new source. (I both try to add a SMB and a manual source with IP and login). I select my smb share and the folder in question.
The folder is added to the file list in the video section and syncing is started.
If I enter the folder a part of the file are listed but 8 are missing. If I exit the folder en re-enter it again, some files can be missing, sometimes the folder is empty, sometimes I can’t enter the folder again with the error “invalid argument”.

For the Music folder, it’s the same. It startes to list the beginning of my folder and then stop. It lists me the firt 6 folder, and then stops. And the folder do not contain all the musics.

What I already tried :

  • start from a fresh install without plugin add-ons etc. no change
  • increase IRP via regedit and DWORD value ( with decimal value less thant 50 or 50)
  • increase DWORD size to 3
  • create account for the smb share to avoid anonymous mode
  • create a SMB source in OSMC with ip login / no login path.

My configuration :

  • Windows 10 build 1511
  • the last osmc build ( 2016.06-2).

And I don’t really know what information I should also provide :confused: . I 'm new to raspberry world, so I don’t really know what to do.

Sorry for the bad english, I’m French :confused:

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us help you.

Thanks for your answer.
I will try to be more specific.

I run osmc on a PI3 B.
I have an i-clever keyboard/touchpad plugged-in and a hard drive.
I use a HDMI cable to plug the PI3 on the TV (LG).

I encounter the problem I described each time I try to connect to a SMB source. none of the folder have all the items in it.

here are the logs:
for the music folder (lots of items on the computer , only few visible on OSMC) :

for one of the movie folder : (26 items on the computer, 9 visible on OSMC)

each source has been added differently : The first one using computer IP and port, and the second one via windows SMB option in the “add source” menu.

Did I forgot something else you could need to investigate ? :s

EDIT : I activated ( or deactivated ? I don’t really know) the option for more detail log info on SMB
here is the log for both folder i did earlier , with the same procedure

EDIT 2 : I use wifi to connect to the network / shared folders