OSMC Stream Issue

I have OSMC RC3 with all updates runing on a rPI2. When i try to stream from Twitch.TV app the stream constantly freezes every few seconds (probably to rebuffer, i have no notifications of that). Statistics say cache 0.I have tried changing advancedsettings.xml but that doesn’t seem to have any impact.
I have no issue with streaming over lan or with other apps like youtube. Also i have tested my connection speed from the osmc machine and its 40mbits/s so that shouldnt be an issue. The streams work on my pcs/tablets.
Any ideas how to resolve this issue?
Thanks in advance,

If it’s only an issue with Twitch, it’s likely a problem with Twitch.


cachemembuffersize in advancedsettings.xml has no effect on live steaming protocols like rtsp, in these cases you will always see a cache size of 0 in the codec info overlay.

The reason is pretty simple - to build up a cache you would have to download the file faster than realtime playback drains the cache - how would you do this on a live stream ? You can’t by definition, unless you had a time machine…

I haven’t used many different streaming applications. The only one was youtube and that worked fine.

Isn’t it possible to build a buffer/cache if the streaming isn’t “live” but with a small delay?
This wasn’t an issue on alpha4 before i upgraded. I have tried reinstalling osmc but no improvement. I have tried to stream from the same source on my laptop and the stream was fine.

I have the very same problem, Addon worked properly in Alpha 4, but not in the current June Build. It doesn’t even help to lower the quality, it is stuttering all over the place!

Is there a way to contact the author in any way? Because the official addons page doesn’t list a website or forum thread.

I have tried to write a post on the kodi (as I understand it, the player in osmc) forum. Got no response. Maybe more voices will merit a response.