OSMC Update Error / Wireless issue


I seem to have a very odd issue where the WiFi is constantly dropping. It’s been working absolutely fine for years and then I started getting the dreaded “OSMC Update Error. Error installing: Please report this on the OSMC Forum”.

Per other posts suggestions I have done:
sudo apt-get update
sudo apt-get dist-upgrade

Nothing of note there. Note that in order to do this, I’ve had to plug in via Ethernet.

Now, the problem I have is that on reboot and even now when there is no data flow, My OSMC shows the wireless adapter as connected and that it has an IP address. I can’t ping that IP or SSH to it.

I could initially after reboot, but as soon as I tried to open a file it dropped.

I tried to generate logs both through My OSMC and via command line (grab-logs -A) but it fails every time saying it can only dump to the SD card.

Appreciate any thoughts on next steps?

This is running on a Raspberry Pi and the only recent change is a search add-on installed. I’ve since uninstalled it and the same issue persists.

Connect Ethernet, reboot twice, issue grab logs command.

Alright, that worked!

Logs available at https://paste.osmc.tv/nikihejopo

The interesting bit for me is…
[ 2.472832] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[ 2.604713] usb 1-1.2: New USB device found, idVendor=7392, idProduct=7811
[ 2.604739] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.604748] usb 1-1.2: Product: 802.11n WLAN Adapter
[ 2.604759] usb 1-1.2: Manufacturer: Realtek
[ 2.604767] usb 1-1.2: SerialNumber: 00e04c000001

Jun 29 21:05:30 osmc connmand[208]: wlan0 {update} flags 4098
Jun 29 21:05:30 osmc connmand[208]: wlan0 {newlink} index 3 address 74:DA:38:00:71:97 mtu 1500
Jun 29 21:05:30 osmc connmand[208]: wlan0 {newlink} index 3 operstate 2
Jun 29 21:05:30 osmc connmand[208]: wlan0 runs an unsupported 802.11 driver
Jun 29 21:05:30 osmc connmand[208]: Adding interface wlan0 [ wifi ]

FYI the USB WiFi adapter (that’s been working OK since 11/2014) is Edimax EW-7811UN 150Mbps Wireless Nano USB Adapter.

Any thoughts on what the issue is here? It seems like maybe the driver for the USB WiFi adapter is flakey with the latest update?

FWIW, I get the same unsupported driver notice running the OSMC 5Ghz USB wifi dongle. It is working fine at the moment however.

It just means we aren’t using an NL80211 implementation (we’re working on it).

Any other thoughts as to what the issue is? WiFi was working fine and then all of a sudden it’s just stopped. All other devices in the house are still fine, so would be surprised if it was a WiFi issue.

It’s working fine via ethernet, but means running a cable across the room so not ideal.

The snippet you posted doesn’t show an error per se.

Try the dongle in another machine to check it still works.

This makes absolutely no sense, but hey - it worked.

I put my modem back into router mode and connected to the WiFi on that (I set a different SSID), it was working fine.

I then put the modem back into modem mode and let my WiFi router take over again. While doing that, I went into /var/lib/conman and sudo rm -rf wifi* to delete all saved profiles (connected via ethernet).

I then connected to the WiFi router SSID and it wouldn’t connect at all, again - odd.

I plugged in the ethernet again, deleted the WiFi profile it created during the failed connection attempt and then I restarted the RPi. I then disconnected the ethernet.

Once it came back, I attempted connection again and this time it connected. It now seems to be working again.

There’s no logic to this one, but it’s working so I’ll take that!

… spoke too soon, it’s just dropped again. Seems to be an issue with the WiFi router, although none of my laptops or other network connected devices are dropping. Will try a factory reset on that, maybe that’ll do it.

Factory reset no good, same issue. Will work momentarily then drops. Will try another adapter (same brand as router), but it seems to be some strange issue with the router and the adapter, from a logical viewpoint so hopefully that will fix it.