OSMC updater not working RPi 2 Kodi 15.2

Female pensioner … very amateur … running OSMC Kodi 15.2 (October 2015) on RPi2 using 8gb usb drive with micro SD start up card. Confluence skin. Pretty stable ethernet connection of 10mbps/3mbps. Have had updates switched off in My OSMC since October update, no running issues experienced and only now trying to bring up to date before problems DO start to evidence. I have tried doing this via both a scheduled and a manual update but it does not progress beyond ‘starting download’. Having not made any attempt to update since the October issue I have no idea how long this has been not working, but several current tries have the same result. I have read about doing an update from the command prompt but before I try, perhaps someone could kindly confirm if this is likely to work or, having missed the last 8 months of updates, is it too much for the OS to cope with and therefore better/easier to do a new install? Full log file uploaded http://paste.osmc.io/joyocesaxo
Help would be very much appreciated. Thank you.


Decided to give the update a whirl via the command line but got in a bit of a mess as you will see from the log. Ran sudo apt-get update successfully, followed by sudo apt-get dist-upgrade which didn’t go quite according to plan as the final line was just below the screen and I could barely make out that it was asking me to say Y/n to whether I wanted to continue as it would use 74.5mb (approx but cant remember exactly) extra space. Unsure what to do I exited then ran sudo apt-get dist upgrade again and (blindly) typed ‘y’ when it came to a stop then ‘Y’ when I realised it should have been uppercase, followed by ‘exit’ after a few moments when I thought it still wasn’t doing anything. Apparently it had begun the process but was terminated mid stream by my premature ‘exit’ command. A repeat try contained a line about ‘unwanted packages’ and suggesting I should ‘auto remove’, before ending once again in the need to use more space and asking for confirmation whether I wanted to continue or not. At this point I thought it best to ‘exit’ again and see if the OSMC updater would now work. It does now work, but when it reaches installation process I receive an uodate error: dpkg (1.17.27) suggesting I report it together with logfile. So here I am, a complete disaster of a user, asking for more help and hoping someone has the patience to assist.

Log here: http://paste.osmc.io/boteruguka

For future use it would be great to know how to scroll down the command screen or reduce the size to fit (flat screen 28 inch TV) so I don’t have to second guess the final line.

The uppercase Y in “continue?: Y/n” only suggested the default action if you’d just pressed Enter, so lowercase y was OK. Regarding logs - you’ll have to wait for someone way smarter :slight_smile:

1 Like

Try running sudo apt-get -f dist-upgrade


Adjust overscan setting on the TV to 1.1 or ‘Just Scan’.

You can also use SSH (download Putty) to connect to the device from your computer where things are easier to read.

Looks like you have some small corruption on your system. Try running the following commands to fix the issue:

sudo -s
apt-get update 
apt-get dist-upgrade -y
1 Like

Thank you Sam. Trying it via PuTTY the >/usr/share/locale/th results in (Input/output error). Is this correct? Do I need to exit out of Kodi on tbe RPi first … its currently on the home screen.

I think your SD card may be corrupted. It may be wise to do a reinstall


@ooZee that makes perfect sense. Thank you. :slight_smile:

@sam_nazarko Oh dear! As I am running on usb stick I assume you mean my SD start up card :cry: Okay - if that’s the only way to go but is it worth trying the other suggestion first? i.e. [quote=“ActionA, post:4, topic:18067”]
sudo apt-get -f dist-upgrade

Than its not your SD card but your USB Stick that is corrupted

Just to say I did try sudo apt-get -f dist-upgrade but with same error result. So a new install it definitely will be. Many thanks for everyone’s responses.