OSMC USB install - WD Red 3TB problem

Hello all!

Have a flawlessly running OSMC PI2 and WD Elements 3.5" 1TB USB HDD setup for more than 1 year.

I want another one OSMC setup with my other PI2 and the WD Red 3TB 3.5" in external rack.
I’ve made the USB install SD Card, and put it in PI2. The install starts, but I got can’t mount root notification. What is the problem or I make something wrong? Does Pi2 supports 3TB drives or problems with Red HDD’s? Please help me. :slight_smile:

The same WD Red 3TB is working ok formatted GPT/NTFS and attached to my working PI2 + WD 1TB setup.

Update: Tried with friends Raspberry Pi 3 and my WD Red 3TB. The same happens. :cry:

Regards!
Rob

I think I was helping you over here:

https://www.raspberrypi.org/forums/viewtopic.php?f=56&t=166510&p=1072819#p1072819

Let’s continue.

Are you happy to try an installer which formats the disk as GPT?

Sam

Sure, i will try it as it’s ready.

diff --git a/installer/target/qt_target/qt_target_installer/mainwindow.cpp b/installer/target/qt_target/qt_target_installer/mainwindow.cpp
index 7cdddc1..e719ded 100644
--- a/installer/target/qt_target/qt_target_installer/mainwindow.cpp
+++ b/installer/target/qt_target/qt_target_installer/mainwindow.cpp
@@ -209,7 +209,7 @@ void MainWindow::install()
         if (device->hasRootChanged() && utils->getOSMCDev() != "atv") // && utils.getOSMCDev() != "pc" eventually.. -- cause we want boot there too.
         {
             logger->addLine("Must mklabel as root fs is on another device");
-            utils->mklabel(rootBase, false);
+            utils->mklabel(rootBase, true);
             utils->mkpart(rootBase, "ext4", "4096s", "100%");
             utils->fmtpart(device->getRoot(), "ext4");
         }

It should only require a one line change.

However, I made the choice to use msdos partition table to preserve compatibility where possible for <=2TB disks on old operating systems that don’t support this partition table properly. So I would prefer to refine the above change to create a GPT label iff >2TB.

Here’s a test build, please let me know how it goes. You can choose ‘local image’ in the OSMC Installer and select this file after downloading it.

Dropbox - OSMC_TGT_rbp2_20161124.img.gz - Simplify your life.

Sam

Thanks for this build.
Installed well, but after installation I’m getting constant loop between black screen and sad smiley on blue background.

A log would be helpful.
You may need to enable debugging manually.

Here is the log:

Thu Jan 1 00:00:08 1970 Starting OSMC installer
Thu Jan 1 00:00:17 1970 Detecting device we are running on
Thu Jan 1 00:00:17 1970 Mounting boot filesystem
Thu Jan 1 00:00:17 1970 Trying to mount to MNT_BOOT (/mnt/boot)
Thu Jan 1 00:00:17 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32
Thu Jan 1 00:00:17 1970 Preseed file found, will attempt to parse
Thu Jan 1 00:00:17 1970 Found a definition for storage: usb
Thu Jan 1 00:01:26 1970 Creating root partition
Thu Jan 1 00:01:26 1970 From a root partition of /dev/sda1, I have deduced a base device of /dev/sda
Thu Jan 1 00:01:26 1970 Must mklabel as root fs is on another device
Thu Jan 1 00:01:26 1970 Going to mklabel with device: /dev/sda with a label type of GPT
Thu Jan 1 00:01:28 1970 Calling mkpart for device: /dev/sda and fs: ext4 with start 4096s and end 100%
Thu Jan 1 00:01:29 1970 Calling fmtpart for partition /dev/sda1 and fstype ext4
Thu Jan 1 00:02:13 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
183148544 inodes, 732566016 blocks
36628300 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=0
22357 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,
102400000, 214990848, 512000000, 550731776, 644972544

Allocating group tables: 0/22357 481/22357 1221/22357 1956/22357 2688/22357 3424/22357 4159/22357 4894/22357 5629/22357 6362/22357 7102/22357 7842/22357 8583/22357 9323/2235710064/2235710804/2235711544/2235712284/2235713024/2235713763/2235714503/2235715242/2235715983/2235716726/2235717392/2235718047/2235718702/2235719357/2235720018/2235720687/2235721355/2235722023/22357 done
Writing inode tables: 0/22357 done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: 0/22357 2/22357 6/22357 done

Thu Jan 1 00:02:13 1970 Mounting root
Thu Jan 1 00:02:13 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:02:13 1970 Using device->root: /dev/sda1
Thu Jan 1 00:02:15 1970 Extracting files to root filesystem
Thu Jan 1 00:02:15 1970 Starting extract progress…
Thu Jan 1 00:03:56 1970 Extraction of root filesystem completed
Thu Jan 1 00:03:56 1970 Configuring bootloader
Thu Jan 1 00:03:56 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:03:58 1970 Configuring boot cmdline
Thu Jan 1 00:03:58 1970 Configuring /etc/fstab
Thu Jan 1 00:03:58 1970 Successful installation. Dumping log and rebooting system

That looks fine.

I actually meant an OSMC log.

I suspect the issue is unrelated, so I’ll merge the above code with some adjustments.

log if its acceptable

https://plus.google.com/118405649891769804561/posts/RwZ71TdLxnm

Suggest you use grab-logs -A to upload logs and provide the URL here

Please help me how to get the log file from OSMC.
I pulled it from the SDCard but can’t get it from the USB HDD.

I am a bit lost here. Can you access your OSMC by SSH? My understanding is you should be ad OSMC starts just Kodi fails.

So if you can access via SSH you can execute grab-logs -A

No, I can’t access, because OSMC is broken. Installed ok, but after crashed and looping between sad smiley on light blue screen and black screen.

It seems like the initial config on SD card is OK, but when the OS is installed on HDD the config changed and the HDD is not working anymore.

Try to access console by pressing ESC

Pressed ESC and logged in.
I’m not seeing everything but i write down what is on the screen.

/var/log/apt/term.log: No such file or directory
/var/log/apt/history.log: No such file or directory
cannot read table of mounted file system
unable to write temporary log to /var/tmp/uploadlog.txt

grab-logs -A

I know and tried it, but can’t execute that command.

So what does it say

osmc@osmc:~$ grab-logs -A
grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
df: cannot read table of mounted file systems
Unable to write temporary log to /var/tmp/uploadlog.txt
Failed

Ok so seems we are stuck with a no writeable root.
Let’s first do the sanity checks.

  1. How are you Powering your external drive? Does it work with the same power and USB Adapter stable on a PC when you read/write massive data?
  2. What kind of USB Adapter is it? (USB 2 or 3)
  3. How are you Powering your Raspberry? Did you ever the the under power warning (lightning bold in top right corner)

After we clarified this questions you might try this option to do a full SD card install (only need 2G card) and attach the USB disk to store media. Run this for a few days.

Alternatively you could also try to reinialize the drive as msdos and try with the standard installer. If that works we know that the problem is gpt related and not hardware/setup related