Osmc user not working on ssh

Hi,

I’ve changed osmc user in /etc/passwd to UID 0 and GID 0 to have root access.

The problem is now I cant ssh because the default password doesnt work.

What can I do?

Thanks in advance.

Stop doing things that don’t make sense. Changing the uid would not be the way to get root access.
Search in the FAQ and forum to see how to enable root access.

To solve your current problem my suggestion is to mount the SD card on a Linux system and reverse the uid and gid back to what it was.

2 Likes

Thank you. It worked.

I’ve messed this up because I was trying to make osmc a superuser. How can I achieve this?

sudo? sudo -s?

2 Likes

I mean osmc always like root, not only in command line.

This would be a terrible idea. I don’t know what you are trying to accomplish overall, but there is certainly a better way to do it…