OSMC with custom local domain


Just installed OSMC Alpha 4, my home network runs with its own DHCP server which provides a local network called ‘home’. Previously raspbmc installations always worked fine with this, responding to pings to ‘raspbmc’ and ‘raspbmc.home’. However since installing OSMC the pi wont respond to pings on either ‘OSMC’ or ‘OSMC.home’ although it seems to respond on IPV6 to ‘OSMC.local’.

SSHing onto the pi and checking out the connman settings that it is getting the ‘home’ domain from the DHCP server but typing ‘hostname -A’ still gives ‘osmc.local’ as the domain name.

Anyone have any thoughts on how I can get the OSMC pi to play nice on my network?


Edit /etc/hosts on the Pi? For the record, I did not have this problem. I run dnsmasq as a DHCP server and the Pi was accessible at osmc and osmc.fqdn.

Cheers for the reply!

Yeah I am running dnsmasq on as a DHCP server as well.

Thankfully this morning I readded the pi to the statically assigned IP list in dns masq and it all just started working.

Probably just something dumb I was doing :frowning:

I too have a custom domain and DHCP set up and have not seen any problems with this. Are you using an NFS install? There was some issues with populating /etc/resolv.conf in this setup but I have fixed this for the next release.