OSMC's August update arrives with Kodi 15.1

Hi!
When OSMC will be ready for i.MX6 platforms?

Regards,
Rafal

Looks good for now.

Thanks for the new update!
Any news on how Cubox support is progressing?
I am considering to sell my Cubox and get a RPi2. What a big failure of Solidrun. Not even Archlinux can be installed now (it could be installed in the past) so you are stuck with OpenElec which is a waste of the fast hardware.

I love the design, fact it has Bluetooth, WiFi and eSata. Could potentially add support for BT streaming-to-my-soundsystem. But being stuck with OE with no prospect sucks.

Support for Cubox this is what I’m waiting for. Any news?

28 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 81.8 MB of archives.
After this operation, 162 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y

Wow 162MB additional diskspace? What makes Kodi 15 so much bigger?

Also, I got an error in OSMC: script parent.py failed so I am using command line update.

Anybody else having the same issue I am having. Certain menus not working, just displaying black screens. I also get a black background vs the blue. Is this a change in the upgrade or did something go wrong with my install?

Upgrade Issue

@sam_nazarko: you were right, i recovered from a backup (disk image) that i made about 1 month ago, i don t know what happened but somehow the system was messed up while applying the july update. now i applied the backup from august directly an everything went smooth, system is up and running and the package manager works correctly.

greetings, bendsch.

After trying to update, a screen flashes during the update saying "OSMC Update Error - Error installing: armv7-remote-osmc (1.1.6)"

This may have to do with another issue I am having which I brought up here (I included a log file): Skin shortcuts error after update

1 Like

Looks like Kodi 15.1 eats a lot of CPU? More than 40% on my Pi B+ while Kodi 15.0 needed only less than 20% for the same task :frowning:
(Kodi theme : Bello)

I was reluctant to update this time seeing as I used a week on last months update getting all my addons working.
So learning from my experience I made an image file of the sd card before I downloaded the update. Turns out this wasn’t neccessary this time. Phew.
All is working, and all is good :stuck_out_tongue:

Mine got stuck with sad face, so I tried updating, im getting stuck at 73%

Hit http://apt.mopidy.com stable/non-free Sources
Hit http://apt.mopidy.com stable/non-free armhf Packages
Ign http://apt.mopidy.com stable/contrib Translation-en
Ign http://apt.mopidy.com stable/main Translation-en
Ign http://apt.mopidy.com stable/non-free Translation-en
Err http://apt.mopidy.com stable/main Sources
Could not open file /var/lib/apt/lists/partial/apt.mopidy.com_dists_stable_main_source_Sources - open (30: Read-only file system)
Err http://apt.mopidy.com stable/contrib Sources
Could not open file /var/lib/apt/lists/partial/apt.mopidy.com_dists_stable_contrib_source_Sources - open (30: Read-only file system)
Err http://apt.mopidy.com stable/main armhf Packages
Could not open file /var/lib/apt/lists/partial/apt.mopidy.com_dists_stable_main_binary-armhf_Packages - open (30: Read-only file system)
Hit http://apt.mopidy.com stable/non-free Sources
Err http://apt.mopidy.com stable/non-free Sources
Failed to stat - stat (2: No such file or directory)
Err http://apt.mopidy.com stable/contrib armhf Packages
Could not open file /var/lib/apt/lists/partial/apt.mopidy.com_dists_stable_contrib_binary-armhf_Packages - open (30: Read-only file system)
Hit http://apt.mopidy.com stable/non-free armhf Packages
Err http://apt.mopidy.com stable/non-free armhf Packages
Failed to stat - stat (2: No such file or directory)
73% [Working]

You are suffering from file system corruption that has made your file system mount read only. Try running the following to perform a scan:

sudo fsck /

Thanks, that was the problem indeed.!

Any idea what caused it ? Do you have a habit of pulling the power without shutting down, or have you had system freezes ?

Was more patches released today? Just got a prompt to install an update. Curious because I thought osmc was on a monthly patch cycle

1 Like

I am receiving updates every couple of days. I suspect they are Kodi patches/updates?

We have been making some changes to diskmount-osmc in an attempt to remedy a situation where some users cannot mount their external drives at boot.

While we normally subscribe to the monthly update cycle, none of us believe in holding back potential fixes or important ones. The monthly update cycle is good because it gives us adequate time to develop and then test, but there is not much of a chance for regression in the updates we have been pushing.

New features and major changes however are amalgamated in to the monthly update for user convenience. This way it’s much easier for them to see what’s new.

Hope that clears things up

Sam

1 Like

Good to know. I’ll hold off on any further updates until the monthly patch cycle, since I don’t use any external hard drives and my setup is finally working perfectly.

I’m having trouble with the YouTube add-on since the update, which I performed last night… I can’t load any videos via Yatse, but also can’t go to e.g. popular channels in the add-on itself. I get an error message telling me to check the log, but I don’t know where the log file is.

Anyone else experiencing this issue?

Kind regards,
M

Starting a new post is probably your best bet

Sam