Out of Nowhere - Things Just Stopped Working

I’m at a loss as to where to begin troubleshooting this. My only thought is an partial system failure where I’ll need a new box?

My Vero 4K is just over a year old (13 months) and starting today

What Doesn’t Work

  • My OSMC in program add-ons won’t open.
  • In Settings, the Manage Submenu option won’t open
  • In Video Add-Ons, installed add-ons won’t open
  • In System Info for Networking, MAC Address and Internet are “Busy”, but I do have IP Address and Subnet showing.

What Does Work

  • Vero 4K boots to its usual internal OSMC with the AeroTajo skin that I installed running
  • I can navigate and go into all top level menus.
  • I can access files off of connected hard drives and play them

My initial thought was this was internet related or the networking portion of the Vero’s internals is dead/fried. However, that doesn’t explain selecting “Manage Submenus” in Settings and nothing happening.

Does anyone have a clue? I appreciate any help and suggestions.

A couple of things to try.

Do you know how to use SSH? Just SSH in. If you can connect then you know the network is OK.

Try resetting the Kodi. (you need to be connected via SSH)

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If need you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

1 Like

Also, since you can’t open My OSMC to upload logs you can alternatively, through the terminal or ssh, type in grab-logs -A and that will give you a web address you can post in this thread for us to take a look.


You can always try a clean reinstall of OSMC but the previous two posts are trying to help you fix your existing install so that you don’t have to set things up again. If you have a very simple setup though that’s trivial to recreate then sometimes a reinstall is quicker/easier.

1 Like

I appreciate the replies and suggestions. I haven’t been able to sit down to remote in and try these ideas as of yet, but I hope to this weekend. If I can get those logs I will post them here.

This did the trick!

It blanked out my personal setup and skin…went right back to default, but I was able to update OSMC and redo everything as it was.

1 Like

I’m glad that fixed it for you. I wish I had an answer as to why this happened in the first place. Since resetting Kodi worked it was clearly some corruption in the Kodi settings. But what caused it is hard to day. The only things I can think of are a power outage, bad addon, or Kodi crashed and corrupted some config files…

If you’re sure you don’t want to rescue anything from your old install you will probably want to reclaim that drive space with rm -r ~/kodi.bak

Do you have installed a custom kodi skin? I´m using some skins and i have similar problems in the past - identified one affected skin as the source of the problem and now i´m using the official plex app (and a plex server on my nas as backend) without any problems!

Yeah, I’m chalking it up to some oddball add-on updating and the system not liking something. I never really removed anything I messed with over the past year, but now I’m back to a pure state so I’m hoping it’s solved.

Thanks, I’ll have to give that a try at some point, but I honestly don’t use the built-in memory of the Vero for anything outside of the OS and add-ons. But who knows, I may need that room at some point anyway! :slight_smile:

I did have a bunch of add-ons installed before it happened that I had abandoned for a long while. Just stuff to test and play with. Since I don’t remember all of them and don’t need much as it is, I’m doubting I’ll find the culprit. #ColdCase

If you didn’t delete the backup yet…

ls -I "resource*" ~/kodi.bak/addons

will show you what you had both stock and what you added. You can compare that to your current clean install…

ls -I "resource*" ~/.kodi/addons