Overclocking option not working anymore in "My OSMC" application

Hello

I’m updating original post with my Rpi info : I have an RPI2.
Sorry for not mention it earlier.
Thanks for the help already.

BRs
/Giannis

Hello

after last couple of updates I 've noticed that is Overclocking option of the “My OSMC” application is not working anymore.
Is it just me noticing this?
Any suggestions on getting it to work?

Thanks in advance,

BRs
/Giannis

How do you define “not working”
Which device do you have?
Provide Logs
To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

I am out without access - but so noticed last night that there was no overclock icon in “My OSMC”.
I did not dig further but had, probably wrongly, assumed that it is not presented on RPi0 (which is what I was experimenting with).

Yes for RPI0 there will be no overclocking settings allowed on OSMC

However, looks like arm_freq is set to 850 in config … but RPi0 should be able to run at 1000 with the current set of chips that they are using. So … I edited my config.txt and rebooted and noticeably better playing HD content over wifi.

The OC stats are set when the Pi Overclock module is accessed. These settings are calibrated for the Pi1 or Pi2, but the Pi Zero doesn’t need overclocking (as it is OC’d already).

The OC config module is disabled for Pi Zero in the version of OSMC that explicitly supports the Pi Zero. People who installed OSMC before that would have still had access to the OC module.

My comment was about the config.txt that RPi reads on startup.
It has arm_freq=850 which I presume results in underclocking of RPi0 if it ships from factory to run at 1000.

Thanks.

We are aware of a bug in the installer which is not correctly detecting the Pi Zero and consequently setting the default Pi 1 overclock, effectively underclocking it. This will be fixed soon.

In the meantime simply edit your config.txt to remove all overclock related lines (*_freq *voltage) and it will go back to it’s default clock speeds on next reboot.

Hi

by “not working” I mean that the option is not any more functional: when click on option nothing happens, I do not get access to menus with overclocking parameters as I did in the past.

I have an RPi2

Provide with us with detailed logs, as you are the only one who has this issue on a RPi2 we would have to check the details
To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.