Pandora stopped working after July update

Since the July update, Pandora gives me an error after trying to connect. I’ve tried uninstalling and reinstalling with no luck and tried the latest update and still no good. I don’t know what next to try other than reinstall the older version of OSMC. Any ideas?


Our psychic is on maternity leave at the moment, so in the interim we are asking people to turn on debugging and provide logs when they say they are getting an error.

I know it is inconvenient, but without our psychic’s help in these matters we are at a complete loss and must look to the logs to tell us what the error is and indicate what solution (if any) there might be.

It’s true, our psychic was only helpful half the time, but that is still a better strike rate than simply guessing. Right?

I appreciate the sarcasism but before I go crazy, I was looking to see if other people have had a similar issue.

While waiting for a response I was trying to figure out how to get to the logs.

Ok, here its the paste in:

It happens just after it says “logging in”. Log says something about missing xml file for window. Maybe its coincidence, but like I said it stopped working after the July update. This is on a pi2 if matters at all.

Thanks for your help!

Well a quick internet search revealed the issue for anyone else who runs into this. Pandora doesn’t like the OSMC skin. I had to change back to Confluence in the appearance settings page.

It would appear that the Pandora addon is obsolete. You should move to the Pandoki addon.