Pi 1 / Zero OSMC_TGT_rbp1_20170321 Build - Rainbow Screen

Evening all,

Just spotted a potential issue with the new build for rbp1 / Zero. When trying to boot the image for the first time on fresh install it seems to hang on the rainbow screen indefinitely. I tried the same install procedure on the 02-2017 build and this works absolutely fine (also tried using the kernel from the 02-2017 build but no dice).

Confirmed SD card is absolutely fine and am using a pi power supply.

Also tried installing it with wired connection to setup manually later but still to no avail.

If you need anymore info please let me know.



Hi Andy,

There’s a reason that image isn’t listed on the website yet – you’ve jumped the gun a little bit. I prefer to test the images before publishing them and we wait a little bit to make sure that the update has been well received in case we need to make any last minute changes.

I bumped the firmware for the installer, so it’s likely trying to load the Pi0 DT, which hasn’t been added. The problem is that our installer uses a very old (3.18) kernel. I’ll bump this in the next month to 4.9 as it is an LTS release.

As we don’t need WiFi or BT in the installer, it’s simpler for me to just use the older firmware now. I’ve now made this change and I’m building the installer again. I’ll let you know when it’s ready for testing.

Thanks for the spot

Maybe a little too keen on my part i admit :slight_smile:

Was more of a heads up just in case you didn’t know about the issue but i know you’re pretty diligent in all you do so just trying to help where i can.

All the best :thumbsup:



Hi Andy

Can you try the updated image here?



No problem - just going to flash it now will report back @sam_nazarko

Check MD5 to make sure you are getting the new one

Will do

Hash looks the same - do you have a cache buster or just have to wait for the CDN to flush?

Hang on - actually hash matches 19:11 upload so it’s the new one :slight_smile:

Ok it’s booted up so :thumbsup: so far. Will report back with further details.

Unfortunately it seems to get to the install screen and says

Install failed: Please contact support. Hardware is faulty

Just waiting on Jenkins to resolve this.

1 Like

No worries Sam. No rush. Give me a shout and am more than willing to help.

Try again now. Check checksums as always.


Sorry fell asleep last night! Will try when i get back from work later on :thumbsup: