Pi 3 stuttering playback of DVD ISOs that play perfectly on Pi 2

I have a fresh install of the latest image - not NOOBS.

A Pi 2 with a wired LAN in an official case plays DVD .ISOs stored on my NAS perfectly. A Pi 3 in an official case with a wired LAN playing the same DVD .ISOs from the same NAS - i.e. the only change to the setup is replacing the Pi 2 with a 3 - suffers from regular stuttering playback where it looks like frames are being dropped. It’s intermittent and I’ve recently SSH’d into the Pi 3 to monitor CPU temperature to try a broad sweep at determining whether the 3 is thermal throttling but I haven’t seen the termperature above 57 but then I haven’t seen the temperature when it stutters. The ambient temperature is never more than 24 degrees C.

Whenever I’ve seen the stuttering, I’ve replaced the Pi 3 with a 2 and the same .ISO has played perfectly.

Has anyone observed something similar with a Pi 3 in an official case and an up to date OSMC installation with no add-ons? The 3 has an official 2.5A power supply.

Have you purchased the codecs for the Pi3? You can’t use your Pi2 codec keys on the Pi3.

Yes, I have new codecs for the 3.

http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

http://paste.osmc.io/tecahijowo

Swap the sd cards from the Pi3 to Pi2, does the stutter follow the card or stay with the Pi?

I’ve imaged different SD cards for the 3 and the intermittent stutter remains.

This log does seem to include an attempt to play a file.

Also, please report what happens when you follow Diligaf’s suggestion.

The stuttering has been intermittent and unpredictable and as soon as I see it again, I’ll swap the 3’s card into the 2 and and also upload another log. Thanks for the interest.

I saw the stuttering again. SSHing for the CPU temperature showed 59 degrees C.

The log: http://paste.osmc.io/egiyoxenuy

I rebooted the 3 and opened the played the same .ISO DVD (‘The Class’ and ‘Frost Nixon’) files that I’d seen stuttering and I played them in the same places and there was no stuttering. I can’t reliably replicate the stuttering on the 3 but also did as suggested and ran the 3’s SD card in a 2 and didn’t see any stuttering.

What happens when you run the 2’s sd card in the Pi3 ?

A bit confused here. Have you tried booting the good rpi2 card in the rpi3 and wait for stuttering… Or are you swapping the cards on powered on units?

Have you tried on the same rpi2’s TV/HDMI/Ethernet line to rule out location problems?

I have both rpi2 and rpi3. Both, literally on the same PSU At the same time. The rpi3 has heatsinks pasted on. Both are using the same high quality SD cards. Both have codecs. Both play locally NAS stored DVD.iso and BD.iso files via wired SMB . no stutter at all. The rpi3 is snappier in browsing and quicker in seeking within 1080p movies.

Dilligaf: I haven’t tried that but I will now, although the 2 has a Kingston SD card that was a pain in the backside initially and couldn’t cope with reboots in the early days of the 2 but has settled down now. The 3 has a Samsung EVO and that batch has behaved impeccably in several 3s. I will report back.

Landspeeder: Booting and waiting for the stuttering is challenging because it is so intermittent. I have tried the 2’s card in the 3 immediately after the 3 was stuttering and played the same files and saw no stuttering but I’ve also simply rebooted the 3 with the 3’s card still in place and seen no stuttering with the same file. The location, TV, HMDI, ethernet is exactly the same when I compare 2 and 3, I swap the Pi and nothing else. Swapping cards on powered units? Why would I even think about that? No. Your described setup and mine is almost identical other than I have no heatsinks on the Pi 3.

Power supply: I’ve just noticed that when I’ve been using the 2 and the 3, powered exclusively by one PSU that the PSU in question is the 2’s original 2A Stontronics. I’ve now swapped this for a 2.5A in case that this is the cause with the 3. The 3 only has a keyboard USB dongle attached and so excessive power draw shouldn’t be an issue.

Good Knightlorish… what I was reading made it sound like you were swapping cards on a booted pi!

My PI PSU is a bit unorthodoix in 1 room as it powers 4 RPI at the same time plus picks up light charging duties now for 2 8bitdo remotes (a pi 2 for ocotoprint, a pi 2 for home security/monitoring, a pi 2 for OSMC, and a pi 3 for OSMC to replace the pi 2). Anker

And there’s more…

The PSU isn’t making any difference, as I’d suspected, as I’ve managed to replicate the stutter this time. ‘Inside I’m Dancing’ was the DVD .ISO, although it will happen with any file (intermittent, you see).

The log for the Pi 3: http://paste.osmc.io/unazoyibex

The different combinations:

3’s card in Pi 3: stutter
2’s card in Pi 3: no stutter
3’s card in Pi 2: no stutter
3’s card back in Pi 3: stutter
Rebooted 3’s card in Pi 3: stutter.

2’s card is a Kingston 16GB class 10.
3’s card is a Samsung 32GB EVO+.

I fully expect that the next time that I try it that it won’t stutter.

As I mentioned previously, the batch of Kingston cards gave problems with the Pi 2 for Kodi and any other use initially and I discovered much later that this had been a known issue of incompatibility with many makes of card that hadn’t really been shouted from the rooftops but work had been done to resolve it. The choice of the Samsung was made after deliberation and following recommendation (http://www.jeffgeerling.com/blogs/jeff-geerling/raspberry-pi-microsd-card. Anyway, enough of Pi SD cards being much more of a pain than “advertised”.

At the moment, my interim conclusion is that it’s either the card or the 3. I’ll swap both and see.

I use, nearly exclusively, Sandisk Ultra. I picked up a kingston when checking an issue with my early Vero2.

1 more thing… willing to freshly install on your Evo in the RPI2, then swap that to the RPi3? Just a curiosity

I think it is more likely to be the contents of the sdcard (i.e. the settings) than the make of the sdcard.
The Samsung EVO/EVO+ is a widely recommended card on the Pi so I’d be surprised if that were the issue.

I’m not expert enough to see exactly what the log files reveal to an OSMC guru but my settings are largely unaltered.

I have altered the memory allocation with 320MB graphics memory allocation on both 2 and 3, could this be something that would affect the 3 differently to the 2 and what value would be more suitable? I haven’t altered any of the overclocking settings from the default installation.

The only other setting that I can think of is playback acceleration. On 2 and 3 I had OMX and MMAL selected and have just unticked OMX on the 3 to see if I can determine a difference.

I use the osmc defaults on both pi2 and pi3 for players and mem

I’ve seen stuttering on both Pi 2 and 3 now on DVD .ISO playback and this perhaps points to the network and I’m puzzled since I haven’t seen it before and I haven’t changed anything. I use NFS, a NAS and a wired LAN.

What can I do to measure network performance at the Pi over a period of time to determine whether network speed variation has become a problem and what is the minimum throughput to ensure smooth .ISO DVD and Blu-ray playback? I hadn’t seen stutter at all on the 2 with both DVD and Blu-ray until yesterday and I can’t match it with activity on the network that may be affecting things. An additional point is that I haven’t seen Blu-ray stutter but must add that I don’t watch Blu-rays as often as DVD .ISOs. It’s not a matter of new ISO images being at fault since I’m seeing stutter on films that have played smoothly before. The stutter remains intermittent.

Pi 2 log after stutter, if relevant: http://paste.osmc.io/evanezetib