Pi reading wrong USB stick when rebooting

I’m running RC 2 on a Pi 2 with a USB install. I have a second USB stick for wallpapers and the like. The problem comes when rebooting. Upon reboot, I see the rainbow screen, but right after, I get a wall of text instead of the OSMC boot screen. I have to pull power, take out the wallpaper USB stick, and connect power from there in order for the right USB to be read. Not sure how to proceed.

It’s probably the old problem of identifying the USB stick.
The boot parameters (used to be in /boot/cmdline.txt, and still appear to be) need to be adjusted to bet the correct device.
I think I’ve seen a posting suggesting using the UUID.
Alternatively you would need to boot with the 2 USB stikc in various slots until you find which is the ‘first’

later: found the older post here which suggests PARTUUID might work, but didn’t see any confirmation of this.

I’m not sure that the OSMC kernel has UUID support enabled. In which case the solution is to physically swap the ports that the two USB drives are plugged into to change the boot ordering to find the correct drive.

Sam gave a quick summary in the linked thread - and the reply was that it worked (PARTUUID presumed)

Swapping USB stick locations may still be an easier solution :wink:

Hmmmm, I’ve tried swapping the USB locations. I think I’ve tried all the combos, but no luck so far. I do have a NAS drive that I store all my movies and music on, but have been unsuccessful in pulling wallpapers from the drive. I feel that if I could pull and use pics from that NAS drive, I wouldn’t need USB #2. Any advice there?

I had the same problem then I tried another USB stick and it reboots with no problems. It was a Verbatim USB stick that was the problem if that helps