Pi2 GPIO remote stopped working

So I just updated (failed updates before ActionA fixed it) and my gpio remote stopped working. My Pi1 is working fine after update, so maybe something changed in Pi2 update. One thing I noticed is I am missing the lircd.conf symlink in my OSMC folder. Reapplying settings for remote doesn’t seem to fix it, nor does changing and then reverting back. Any help please?

edit: I created a new symlink and it still isn’t working.

edit 2: so after running:

sudo systemctl status lircd_helper@lirc0

It seems lircd is not running?

 lircd_helper@lirc0.service - lircd remote support
 Loaded: loaded (/lib/systemd/system/lircd_helper@.service; static)
 Active: inactive (dead)

Please upload your log files.

Were you using one of the built in remote profiles or a custom one. Have you tried reselecting your remote profile in the remote settings and then rebooting ?

Yeah, tried all that. No worries, Thread can be deleted. I reinstalled. Something happened with a failed update earlier today, I guess the servers were offline? Kind of disturbing, I tried all sorts of fixes, but in the end just reinstalled.