Pi3 Froze Mid-Update (And Freezes Daily)

I was updating from the October build to the latest version which was only released a couple days ago.

My pi started freezing about a month ago, and last week the freezes had become very frequent (almost daily). These freezes would happen only if the system had been idle for more than a few hours. I figured updating could help with the issue but the update didn’t go as planned either.

Mid-way through the update. I got a bunch of errors and I’m quite sure it’s stuck now. I can ping it but can’t SSH. After the above-mentioned freezes, I wouldn’t be able to do either.

Here are the error messages: Pi Update Errors - Album on Imgur

I think I’m dealing with a filesystem corruption issue here. So, I have two questions:

  1. Am I safe to do a hard reboot?

  2. How do I fix whatever is wrong?

Well everything is broken already so the hard reboot will at least don’t do more damage

Well I believe you would need to do a fresh install. Before that either get a new SD Card or test the card with H2testw

Yes, test the card. If it seems OK, you should worry about your power supply.

Alright. Here are a few updates.

I did a hard-reset and surprisingly everything went back to the way it was. Literally everything. I ran fsck and configured the pi so it would force fsck at every boot.

I’m using the official power supply so I don’t think that’s the problem.

That being said, when I tried to update again through SSH using dist-upgrade, I got the same errors. One of the filesystem errors, this time, said “This should not happen! Data will be lost!”.

I’ll try to test the SD card on my mac and report back here.

Your card might have gone read-only. Time for a new one.

Ah, there’s another catch. Once the first few errors pop up, I get a report saying that the volume is being mounted read-only. I assume that’s what allows me to revert to the previous version.

After rebooting though, I have been able to run apt-get update as well as dpkg so I’m pretty sure I can write onto the card.

So just try apt-get dist-upgrade again (twice).

had similiar issues updating. Noticed before the update skin changes werent being saved.

Tried transfering few files to sd card from pc. When unplugged and inserted micro sd again the file wasnt saved. So sd card gone bad.

Luckily made a clone of my card few days before. Reimaged new card and update went fine.

I’ve been able to edit skin settings and use apt-get update.

I’ll clone the SD onto my Mac and try it once again. If it keeps crashing, I’ll try it with a new card and report back.

Are those changes still there after a reboot?
Definetly suggest to do a image of the card and test the card with h2testw. If card OK you can write the image back. If H2testw fails you can dump the card.

Yeah. All the new packages are there. Skin changes too. I modified the menu for example, and every change was kept.

Pi seems to be back to the way it was: Daily freezes. When it freezes, I can’t SSH into or even ping the device. The SD LED never lights up, and all I see is the thermometer icon on a black screen. I’ve checked the logs but I really can’t see what could cause it to overheat. Again I emphasize this only happens when the device has been idle for a while (more than a few hours).

Can post logs if needed.

Suggest to investigate why the device overheats.
Bad ventilation or is there a application running the CPU?
Open ssh session and watch htop

Never harms

There are a number of threads on freezing on long idle, eg Crash or freeze after long idle. The poster added a heatsink to his Pi.

I looked at those threads. One user had a bad power supply, the other was overclocking, this guy had a library 370 subfolders deep… I have none of those problems. Nothing described in those threads applied to my pi which is why I opened this thread in the first place. Nothing in the few threads marked as solved helped me at all.

https://paste.ubuntu.com/26363503/
These are from two days ago but the problem were exactly the same at that time as well.

Ok good. Sorry if I’m getting a bit confused as this started out as an updating issue and now you are saying it’s a long-time idling problem.

I hope someone else can spot the problem.

That are only kodi logs. Please provide full logs via grab-logs -A
Also check what is using your CPU with htop

Here you go: https://paste.osmc.tv/borunopeve

Also, I’ve been checking CPU usage throughout the week. Nothing unusual. Idles at 15% and the system is only under heavy load during library updates or just after boot.

So I assume currently you don’t see the high temperature?

Nope. I only see the thermometer icon after booting while everything starts up (or during a library update). Also, the pi never freezes in these scenarios. After a few idle hours, however, I see a black screen, an unresponsive pi and the thermometer.

I’m watching a 1080p video right now at 58 degrees.