Pi3+ skip/stutter/sync playback with LOTR ISO

I get studdering/stuttering with bad audio sync but only when playing Lord of the Rings Bluray ISO image. Other ISOs work fine.

Hardware:
Two units of Raspberry Pi 3+ in a FLIRC case with Samsung 64GB EVO SD.
One has a CanaKit PS, the other is Micro Connectors brand. (Both are marketed for Pi3 and have 2.5A or more)
Each box is connected to a different [3D] TV.

Network:
Gigabit Ethernet (aka 300Mbps)
Synology DS416+ (hosts ISO images)
Pi is connected using Windows SMB

Software:
1 box is running LibreElec Kodi 18.
1 box is running OSMC Kodi 18.
I am running AnyDVD HD on the PC to create the ISO images.

Problem:
The LOTR trilogy just will not play without significant lag of video and skipping of frames. (audio precedes video).
Note that I am able to stream about 30 other bluray disks, also ripped with AnyDVD HD without any problems, including 3D movies in full-frame.

What I’ve tried:

  1. Rip’d LOTR Bluray to ISO image to NAS. Play ISO image on Kodi streaming from NAS. (stutters, all 3 movies do the same thing)
  2. Created MKV of main movie + audio track with CloneBD without any recompressing. (stutters)
  3. Copied un-recompressed MKV file (from attempt #2 above) to SD, and played file from SD (stutters)
  4. Recompressed entire movie with Handbrake and audio passthrough (works great, doesn’t studder, but I prefer not to have the recompression loss, and would prefer to have the full ISO image and extra content)

Max CPU temperatures is around 60’C as reported by Kodi
Ram is at 48% utilization.
CPU #0 and #1 bounce around such that one is ~100% during playback.

I’ve tried turning every knob on Kodi I can think of: Audio passthrough, auto display sync adjust at start, disabled interlacing, disabled remove black frame, etc. etc. etc.
I get the same thing on both boxes.

So, I’m wondering if this is just some strange limitation of the Pi 3+ and Kodi?
Or if there is some setting that could be changed to make it work?
Can anyone confirm whether they can play a LOTR Bluray ISO image on a Pi without issue? or alternatively, has anyone else run into this problem?

I’m at my wit’s end, but open to suggestions.

Do you have the version that is encoded with VC-1 and if so do you have a license key on your Pi’s for that? It wouldn’t surprise me if that particular release pushes that hardware past what it can do with just CPU decoding.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

@ubiquityman mediainfo would help aswell

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC.

You can also create the mediainfo-output of the affected media file on the OSMC device:

  1. login via SSH, user osmc, password osmc
  2. if not already installed: sudo apt-get update && sudo apt-get install mediainfo
  3. cdto the directory containing the video/audio material in question
  4. since mediainfoonly needs to read the header information of the file data, copy the first 4 Mbytes of the media file to a new file:
    dd if="<media file>" of=purgeme.bin bs=1024 count=4096
  5. upload the decoded media information using
    mediainfo purgeme.bin|paste-log
  6. publish the returned URL here in this topic
  7. remove the created media file snippet
    rm purgeme.bin

Thx for your help.

@Tom_Doyle,

Thanks for the tutorial post. Much needed.

If I have completed the tasks correctly, you should find the two text files here:
https://drive.google.com/drive/folders/1V8rCgukQrJBwAgQB3Covb2zg1zCvC6fJ?usp=sharing

A bit of explanation on the log.

When I first started the log file, I played “Guardians of the Galaxy 3d.mkv” file.
That file plays fine. (I realize I need *.3d.sbs.mkv to force 3D, but it’s inconsequential since it still will not play FullFrame 3D correctly from an MKV)
CPU was not well below100%.

Part way through the log file, I played “The Lord of the Rings - the Fellowship of the Ring.mkv”.
CPU load as displayed on the top left corner of the screen was over 130%.
Significant stuttering and sync problems.

You didn’t follow the instructions. Don’t post to your google drive.

I did look at the mediainfo and LOTR is VC-1. Have you purchased the VC-1 license for the Pi?

1 Like

I did upload the log file as well, but I thought it was just a text file so I thought it would be more convenient to include in GoogleDrive.
Here’s the upload to OSMC:
https://paste.osmc.tv/abuvemasox

I did not purchase VC-1 (didn’t know about it at all).
I just finished reading about it, so I will go ahead and do that.
That sounds like what the problem might be…it’s doing software decoding when it can do hardware decoding.

Since I currently have 2 PI devices. Are the licenses by device or by user?
(ie. do I need to purchase a license for each device?)

and once I get the license, if I reformat the SD card to a different Kodi version, is it straight forward to re-install the license key?

Also, what is the best way to purchase the license? Through the Pi webiste?
http://www.raspberrypi.com/mpeg-2-license-key/

The license is by device. And once you’ve purchased it, it’s installed to the firmware so if you do a new installation on a new SD card it will know that it has the license.

The Pi site is the only place you should purchase it from.

Thanks for the help and info. Much appreciated.