Pi3 Upgrade No Go

I went from Pi to Pi3 to speed up my system. Now I cant even get going. I definitely have a connection I see my videos but it wont go. At this time I even disabled wifi and went wired to the router. I can upload logs so definitely online. My server is windows 10.

Sorry if the log is bloated, I don’t know the section. Its has never worked on the new pi3.

Log osmc log

Well to exclude your connection from the problems the first step of troubleshooting always is to copy the file onto the SD Card and play it from there. If that works we at least know better were to look for an issue.
Especially as this points in that direction

21:46:38 432121.343750 T:1566569456 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
21:46:38 432121.343750 T:1566569456 NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 1


could not find codec parameters for

Check out the file with mediainfo.
Please see the mediainfo section in How to submit a useful support request - General - OSMC

Last but not least, I hope you also ensure to have a proper powersupply for the Pi3

So I threw some files on a usb stick and they played fine. So the problem seems network or settings related streaming from the other pc. My server is windows 10, files play off the server fine for that pc only.What I don’t understand is if they scrape ok, why is it not playing ok. I see all the shows, seasons and episodes. It scrapes and downloads little clip art for each show. I feel like it is so close.

On a side note I was looking at my micro sd card, I was going to throw a video file on the direct os card. I use a 16 gb card for the OS but when I was looking closer its setup as FAT32 and only recognized as like a 100 mb card or something silly small. This is a brand new SD card. Thanks for any info.

It’s only seeing the boot partition. That’s expected.

So anyone have ideas. It seems network related.I see and scrape the files ok. It act’s like it wants to start playing there is a long delay then it fails. My pi1 had no problems, I upgraded simply to get better speed off the pi side from being laggy.

I’m having the same issue, went from pi 2 to 3 and now can’t stream anything. It gets to opening stream and a glimpse of the loading wheel but never plays. I tried using both the built in wifi and a dongle, nothing seems to be working yet.

Does anyone have test ideas? Should I bail on pi for fire stick and kodi?

As suggested by fzinken, you should:

Check out the file with mediainfo.
Please see the mediainfo section in How to submit a useful support request - General - OSMC

There’s also something here that suggests that if you try to play the file from Video → Files instead of from the Library, it might work.

Give those two things a try.

This worked magically, until the windows 10 anniversary update. Windows jacked something else up.

Disabling “Large Send Offload (LSO)”

Large Send Offload is a technique of improving network performance while at the same time reducing CPU overhead. Apparently it does not work very well, so it was suggested to disable it. If you would like to know about LSO, check this MSDN article from 2001 (Task Offload (NDIS 5.1) (Windows Drivers)).

LSO is an option located in a Device Manager under your network adapter, so this solution requires Administrator Privileges.

Follow these steps:
1.Open Start Menu, right-click on Computer and select Properties
2.Under Control Panel Home located on the left side of the window click on Device Manager
3.You will get a list of all devices on your machine. Expand Network Adapters.
4.Find your Network Card and double-click on it.
5.Select Advanced tab. You will get a list filled with different options.
6.Select Large Send Offload V2 (IPv4) and set the value to Disabled
7.Do the same for Large Send Offload V2 (IPv6) if it is available
8.Click OK

After clicking OK, tried to send a file over the LAN network. Transfer speed started very slow, but it was gradually picking up speed. Decided to restart the computer and try to send that file again and this time it worked like a charm.

Now that sending of files worked as it should, also checked speed for receiving files. It turned out that it was still slow but all that was needed to fix was to disable Large Send Offload V2 on the other computer. Once done, problem was solved for receiving files as well.

The windows 10 anniversary update broke my pi3 because it turned some basic security on that I previously had off.

If on Win 10,
Start>settings>network/internet>change advanced sharing options>all networks>file sharing connections

I set file sharing to “Enable file sharing for devices that use 40- or 56-bit encryption” I also turned off password protected sharing.

Boom all back to normal.

Thanks for sharing this information. I’m sure it will help users in the future who are unfortunate enough to be running Windows 10. :innocent:

1 Like