Pi3 w/ OSMC not displaying media on NTSF HDD

Mostly in the title. It worked fine in FAT32, but now that i had to switch it to NTSF because of an issue of loading larger sized movies onto it, it wont show the media. It will show the HDD tho, but when i click it, it goes no further. I read a couple threads and didnt realy understand what people were saying lol

Just to be certain, i cleaned out the miniSD and tried it again and the same issue, so no addons are conflicting.

Also, slightly new to all of this, i am somewhat familiar with ssh so if i need logs just tell me what to do lol thanks guys.

It’s in the link, nice and simple…

wasnt sure which logs were needed, but heres all of them, thanks.


Looks like the pi 3 is not capable of providing enough power to the MyPassport HDD. Do you have a powered hub to connect it to?

Huh, thats weird because its worked just fine when it was fat32 formatted. But no, I dont. Its a (not certain) 2 TB passport HDD? With no external power, only connected through USB. Does it being NTSF require having more power?

Edit: To confirm what you said, i hooked up my Book HDD to test, and it showed up. So I guess the next step is figuring out how to get more power to my passport. Ill google around, but do you have any recommendations? Thanks

I wouldn’t think that having it as NTFS would make much difference vs FAT, but powering a USB drive from a Pi usually is flakey. As @ActionA suggested, try a power supply or powered hub.

What do i need to do it? Currently its a USB 3.0. I have a cord that i remember using when i was trying to get the usb working that the manufacturing contacts sent me, its got a usb to a splitter leading to one usb and the other side a micro usb and i cannot for the life of me figure out how i set it up when they were helping me lol but im pretty sure the issue before was getting enough power to the HDD.

So thats what i have on me atm

You’d have to check the specs on the cable, but the micro connector may be for power. Otherwise, just get a powered USB hub.

Why exactly did the manufacturer send you a special cable? That sounds a bit suspicious to me, as I’ve never needed to have a manufacturer send me a cable for something as simple as a USB drive. If my guess is right, they sent you a cable with a power connector specifically so you could power the drive :wink:

Man its been so long, but basically i was only getting usb 2.0 wire/read speeds and they sent me a cable (like previously described, usb to usb/micro usb splitter) in order to trouble shoot the problem. But atm i have that cable, the HDD, and the cable on the hdd (not sure what the name is but whatever the usb 3.0 connection to usb). Is there anyways i could use what i have now with a usb power hub to troubleshoot the problem?


Edit: also, the HDD only has the special usb connection, otherwise id hook that HDD right up the to cable they sent me. If i had a usb to usb connector i could probably do the same

I would think that it would be safe to plug the micro connector into a power supply (but if you try it and it fries your drive, don’t blame me :wink: ). The sure safe way would be to simply get a powered USB hub. Plug the drive into the hub, the hub to the Pi.

Assuming that you still refer to the mypassport it should not have a “special” but just the standard USB 3.0 Micro Connector (which is different to the USB 2.0 Micro connector.
Also while most likely not related to your problem some mypassport were shipped with USB cables that only worked when connected to USB 2 but not when connected to USB 3

So basically i plugged my passport into the 1A and 2.1A part of the powered hub (this being micro usb to hub) then the usb end of that same cord to the pi and it still didnt work :\ is my HDD just screwed up?

This is a bummer lol

Can you take a picture of your setup because I fear some misunderstanding.

1 Like

I guess the next thing to try would be to connect the drive back to your PC and see if it’s still working. Maybe try reformat it if it does work connected to the PC.

Im certain im messing something up, just plugged the same setup into my pc and it didnt show up lol heres what im working with Screenshot by Lightshot

Ok, so the cable on the left is a standard USB3 Mirco cable which is the one to be used with the drive.
I would not suggest to use any of the stuff in the middle on the table.
Coming to your powered USB Hub (I assume the white tower on the right) What does the powersupply of that powered Hub read as a power?

1A and 2.1A

From your picture, am I correct that you are not running Windows? I can’t tell for sure, but isn’t it linux? If so, why are your formatting NTFS, you should use EXT4.

Hell no, cant you tell from my responses that id be running windows? haha, linux is way over my head, im a windows noob for sure

That is the confusing part. So the powered USB Hub doesn’t have a dedicated powersupply? And you use a charger with different outputs?