Pi3 with 5.1 channels audio

Did a search and didn’t see an answer. I am running the latest OSMC with 17.4 kodi.
I have a few movies Ei: The life of Pets that the music channels are there, but not the dialog channel(s). This happens if I am playing thru Kodi itself or with the Plex addon. My Roku with Plex plays it fine? Wondering if I just messed up a Pi3 setting or a OSMC or Kodi setting. Suggestions?

When playing the videos you might try bringing up the Kodi codec information overlay and see if that tells you anything. From a keyboard ‘O’ (that’s a letter, not the number) will bring that up. I have that mapped to a key on my remote so I can pull it up when needed.

http://kodi.wiki/view/Keyboard_controls

There is a link there to the old (Kodi 15 and earlier) Codec info page, but Kodi 17 uses Player Process Info, so some of that info isn’t really helpful anymore.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

So I have a similar problem to this: I think they may be the same thing so let me share some details.

  1. I have passthrough audio enabled on a Raspberry Pi 3 running the latest OSMC.
  2. When I play some audio files the beginning will be AC3 stereo encoded (for the “previously on” bits etc) while the main show is full AC3 5.1.
  3. When the main show with 5.1 audio starts, Kodi/OSMC seems to keep sending a stereo stream so there is no center channel: thus the dialog is inaudible and you only hear stuff like music or other sound effects
  4. The temporary fix is to toggle “Allow Passthrough” off and on from the Audio and subtitle settings popup menu while the movie/show remains playing. Then you’ll hear the correct dialog again but the problem will re-occour on the next thing you play with this kind of Stereo Intro.

@tannenba can you check to see if this matches what you’re experiencing? Then we can work on a more permanent fix.

(BTW to get to the right popup menu: hit select or equivalent on your remote while watching video, then navigate to the speaker/sound icon)

Not sure which logs are needed and where to get them. Looked in /var/log and didn’t see anything useful. I will try that codec info when trying that film again. I’ve only noticed it on one or two films in my library. Doesn’t seem to happen when going to a repository for a film. My library is local fileservers. Just thought I would see if there was a suggestion for a setting I might have missed. Most everything runs good on this Pi. I have a tickbox and it is not near as good.

Will try this when I have some time available. Thank you.

The link @bmillham provided contains simple detailed instructions.

2 Likes

Codec: aac, 32 bits, 48khz
channels: fl, fr, fc, lfe, bl, and br

and nickv2002: No, toggling pass through didn’t help.

Are Kodi audio settings set to 5.1? Set them back to 2.0 and test. You’ve told us nothing about your audio hardware or is it only your TV?

yes kodi is set to 5.1. Audio is a Viso 5.1 channel Sound bar, Dolby and DTS capable. I did try 2 channel before, no help with this. Since I’ve only found one or two movies and only in my own library, I didn’t think too much of it, but my Roku and tickbox play the files ok so I figured I missed a setting when I set up the Pi3. I bought and set up the Pi3 because I was unsatisfied with the tickbox tv. I have 3 other Pi’s running Debian Jessie and have been impressed with them.

Do you have Allow Passthrough enabled? If it is enabled, I’m asking again for logs please.

As requested previously, we need logs to get a better understanding of the problem. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Yes, tried passthru enabled and not. Debugging is not turned on and I’m out of time for awhile. Leaving town for a spell and will be away from my unit. Will respond upon return.

Was able to look at this page…Yes setting to 2 channel works.

If you are using passthrough, you want Kodi set to 2.0 so that audio data is sent “untouched”.

Will do that… Not home now, but that make sense.

Thank you.

This solved the problem. Didn’t see anything about it, or missed it when I set up and just said I have 5.1 channels.

Thank you