Ping and latency spikes with OSMC on

Sort of new to the whole OSMC thing but familiar enough with Kodi/XBMC to get everything up and running. I play games on my computer and ever since OSMC installation I’ve noticed huge ping spikes when the raspberry pi with OSMC is on (even while inactive, in “sleep” mode). Turning off or unplugging the pi solves the issue immediately.

This observation is backed up by ping plotter, showing spikes as high as 1500-2000 ping every minute or so (normally sits at about 20-30). I’ve also ran iptraf but it’s not picking up anything strange, likely because OSMC isn’t running during the test (unless i did it wrong…?).

Wondering, has anyone else ran into this issue? I found a thread on this forum that suggested a clean install of OSMC, that did not work for me. In the meantime, I’ve disabled SSH and Samba but still have the same issues with very inconsistent ping. I only have one add on installed (the most popular one, unnamed here per the rules), and an HDD with my music connected. Everything else is stock at this point.

Totally at a loss - I’m guessing something within OSMC is chewing up my bandwidth and needs to be deactivated. My computer and pi are both hooked up to my modem directly, via ethernet.
Anyways thanks for the help and if I can provide any additional information let me know.


You probably have a pirate add-on which is causing this. Most phone home and cause large amounts of network traffic.

Try disabling add-ons first. If the issue still persists check iftop/netstat/tcpdump. But I suspect after you disable the add-ons the issue will go away.

Only other thing I can think of is if you have a Windows 10 client on the network. Windows 10 and Avahi from OSMC are not friends, so you get a bit of announcement spam, but this shouldn’t be noticeable on a modern home network. Does sudo systemctl stop avahi-daemon help?

Appreciate the help, thank you. I’ve done a full clean install of osmc and still have the same issue. I haven’t added anything to it, completely stock/out of the box. Ive just been letting it sit in the main menu while ping plotter does it’s thing.

I do have a windows 10 client on the same network (my main pc via ethernet)… but after trying the command line you suggested I am still getting the same latency spikes every few minutes. Any other suggestions?

Don’t know if it helps but my internet is usually around 50mbps.

I don’t have any suggestions unfortunately. We haven’t had any reports of this issue before.

Downloading something like WIreshark and using tcpdump on OSMC may give you some clues as to what is going on.

It may be interesting to know about how your Pi is actually connected to the network. If it’s wired, you could try moving the Pi to another switch, to rule out something like flow control being the issue.

Thanks again. Is there a step by step on how to do this within OSMC? I couldn’t find any clear direction online.

Regarding the pi’s connection to the network, it goes something like this:

Cable modem goes to pc directly via ethernet, and cable modem is connected directly to the pi via ethernet. No splitters or anything, just using a different LAN ethernet port on the modem. It’s a pretty simple set up.

There is no step by step guide unfortunately.

Try add smsc95xx.turbo_mode=Y to /boot/cmdline.txt

1 Like

gonna see if that setting has any bearings on my installations since i got lag spikes from time to time

Didn’t seem to have any effect on my network, unfortunately. I suppose the best solution is to keep turning it off when you are trying to do something network intensive, and turning it back on as needed. Not exactly an elegant solution so if anyone has any future suggestions I am willing to try them!

Another power supply?