Playback of packed 3D (3D ISO)


Ok so just to clarify, the people that don’t watch 3D are unaffected. They just keep doing what they’re doing. Just the people that want to use the 3D need to change back an forth as and when they need to? If they set it as 3D it will stay on 3D until they change back to 2D.

I’m ok with that personally. One vote here.


Not quite. It’s better to fix it properly than have people have to go through several menu options every time they play a single file.


But isn’t it also better to at least give us the ability to play 3D by manually changing the decoder, than to not have it at all, isn’t it?

Right now I have to switch to a different device completely, my Zidoo X8, which usually doesn’t actually work when I go to watch a 3D movie because it’s probably been a few weeks, and it’s crashed, or config got hosed, because the device is kind of a piece of junk. It usually takes me 10-30 minutes to get it working. Sometimes it’s just easier to go find the blu-ray. But it is actually capable of playing 3D MVC. And I’m one of the lucky ones who actually owns something AT ALL that can play 3D.

So I’d much, MUCH rather be able to just go and switch a setting than keep dealing with that device. I can’t think of any argument for not giving us this way to play 3D even if it’s not 100% convenient yet.


BTW I just got my “1 year anniversary” badge on this forum. My first post was on this thread. :neutral_face:


I couldn’t find the original test build, so I will need to recompile it on top of the latest changes.


It’s here:

Obviously there’s no support for this and the limitations have been covered above.




Could you not read the “Video stereo mode” from the mkv for the 3D detection (i believe makemkv automatically adds this to the files)


I tried this build. I could see that it does decode MVC MKV. The output options are SBS or TAB. Those modes are indicated in the output and display does switch to those 3D modes. However, the SBS output is not correct. The output is still TAB. TAB output mode looks right. I didn’t see any framepacking output option. I tried these commands, but nothing happened. Actually, I got permission denied for the second command.

  1. echo 3dfp > /sys/class/amhdmitx/amhdmitx0/config
  2. echo 1 > /sys/module/amvideo/parameters/framepacking_support
  3. echo FAKEVIC > /sys/class/display/mode # force reset
  4. echo 1080p24hz > /sys/class/display/mode


Did you

sudo bash

before running the commands? You probably need to run them as root.


As root, the commands are OK. After the force reset command, there is no video signal. Only a reboot restores the signal.


Maybe try without the reset then? I don’t have a 3D tv (or any source) that I can test with, so just guessing)


Commands #3 or 4 ends up with no video signal. Will wait and see what @sam_nazarko has to say.


Wait… There is no framepacked output option? So it’s all half resolution?

Sigh. Like I mentioned almost a year ago if that was good enough for me, i would just encode everything to SBS in the first place and this would all be a non issue. I guess this still really hasn’t gone anywhere.


Did you enable Frame Packed Video output in settings? Those commands are from January and are no longer applicable.

It’s almost impossible to detect presence of a display supporting FP modes. So we give them SBS by default unless they manually enable support.


I haven’t tried it, I was just responding to observations from @wesk05. Are you saying framepacked output is actually supported?

I am very much looking forward to trying this when it shows up in a regular release - even if it requires manual decoder switching - but I don’t have time to hack at dev builds right now.


The goal is to provide Frame Packed output for displays that support it and a SBS or TAB fallback for those that don’t



It’s coming home

3D’s coming home


I don’t think I saw any setting related to frame packing 3D ouput. I remember only seeing side by side and top and bottom. I can check again tonight.


How do you install this file? Is there a guide? I searched and I’m not really sure. If I do install it does it mess up fstab setup?


These are the 3D options in “Player” settings. You can see that all of them are enabled. I still get only SBS and TAB outputs. As mentioned earlier, SBS output is probably TAB with incorrect 3D structure signaling.