Playback Stops and Starts

I have been having issues with playback. It starts and stops the entire time.

The PI is connected to a wall socket and is connected via Wifi. The video is stored on a remote NAS.

I have tried playing the video from the NAS directly from my laptop and it streams fine. I have also checked the WiFI link with wavemon and get +95% at about 72Mbit/s

The logs for when it was starting and stopping being at around 16:47, example below:

16:50:03 1607.717651 T:2822763552 DEBUG: OMXClock::OMXSetSpeed(0.000) pause_resume:1
16:50:24 1629.268188 T:2822763552 DEBUG: CDVDPlayer::OMXDoProcessing Resume 2.83,8.71 (A:00 V:00) EOF:0 FULL:1 T:16.00
16:50:24 1629.268799 T:2822763552 DEBUG: OMXClock::OMXSetSpeed(1.000) pause_resume:1
16:50:24 1629.401733 T:2865755168 DEBUG: script.module.osmcsetting.updates : - blurp 977 - VideoFullScreen.xml
16:50:47 1652.543823 T:2822763552 DEBUG: CDVDPlayer::OMXDoProcessing Pause 0.03,0.11 (A:10 V:00) EOF:0 FULL:0 T:16.00
16:50:47 1652.544189 T:2822763552 DEBUG: OMXClock::OMXSetSpeed(0.000) pause_resume:1
16:51:02 1667.378784 T:2822763552 DEBUG: CDVDPlayer::OMXDoProcessing Resume 2.85,8.83 (A:00 V:00) EOF:0 FULL:1 T:16.00
16:51:02 1667.379150 T:2822763552 DEBUG: OMXClock::OMXSetSpeed(1.000) pause_resume:1
16:51:14 1679.476318 T:2865755168 DEBUG: script.module.osmcsetting.updates : - blurp 977 - VideoFullScreen.xml
16:51:36 1700.747070 T:2822763552 DEBUG: CDVDPlayer::OMXDoProcessing Pause 0.07,0.26 (A:10 V:00) EOF:0 FULL:0 T:16.00

Full logs at http://paste.osmc.io/ifufopajux

Any ideas?

It’s likely the wifi connection’s speed isn’t stable. Test with an ethernet cable, or copy the file to sdcard or a directly attached usb stick to confirm that’s the only issue.

Setting buffermode to 1 may help by including additional buffering: http://kodi.wiki/view/HOW-TO:Modify_the_video_cache

Well I copied some of the films to a External HDD and connected that directly to the PI and the films played fine so it must be what you say an issue with WiFI.

I don’t understand as the WifI router is only about 3m away. It is however a standard BT HomeHub 5 so that might be the issue.

Do you think increasing the buffer or something would get around the issue or just a better wifi connection or ethernet cable is required?

If it’s only 3m away then get a cable. Ethernet is much faster and more reliable than any wifi.

You can try buffermode=1
http://kodi.wiki/view/HOW-TO:Modify_the_video_cache

which may help if the wifi is fast enough on average, but has small dropouts (the extra buffering will overcome that.
If the wifi is not fast enough then that won’t help.

I cannot try the ethernet cable yet but tried the buffermode. I read that it is set to 20mb by default. On turning the buffermode=1, when I play a video it takes 1 min to play due to the buffer filling up.

I think this shows the WiFI speed is very poor if it takes so long to fill the buffer.

I will have to look into ethernet over the powerline as a direct wire is not possible.

Thanks for the help