Playing Files From NAS

I have a Synology DS416slim NAS and an external HD hooked up to it’s USB port (USB 3.0). When I try to play files from a folder on the external HD hooked up to the NAS, it’s a constant game of pushing the play button, the file playing half a second and then quitting. Sometimes I can catch the video and pause it (and I see the buffering bar fill up a little) and then play it again and it works. But sometimes I have file that will just refuse to play. These aren’t big files either. Maybe 1gig or 4gigs.

I’ve had this HD hooked up to the NAS for a long time and this has only started happening in the last few months. Previously it’d worked smoothly with any file I was playing from the external drive.

I’m not sure how to diagnose this and would appreciate some help.

First step is to upload some logs so that we better understand how you access the NAS.
Either why the Menu -> MyOSMC -> Log Uploader
Or via command line grab-logs -A and share the URL

Oh, man. I had no idea there was a log uploader. Looking at the log now, I realize that the external drive was being accessed by SMB instead of NFS. I thought I’d changed them to NFS a while ago after reading about folks having similar problems with SMB. But, I guess they’d switched back somehow when I redid my modem/router setup recently. Once I switched them back to NFS, it seems to have worked itself out.

Thanks for your comment and help!

1 Like