Playing UVC USB Video Class device

Hello,

I have OSMC installed on a Raspberry pi 3b and it works fine except for a small detail.

I am trying to display a UVC device on my screan connected through HDMI. I have been googling for a day now and I can’t seem to find a solution.

I tried creating and opening a .STRM file inside kodi with the following line inside
dev/video0 but nothing happens.

Is there another way to access this stream ? I tried the device and it works fine on a windows computer and acts as a webcam.

Would an external player like mplayer be a solution ? Would it work if installed on top ?

Thank you for your help !

I don’t think Kodi is the best solution for this. You may wish to use Raspbian. I would first check that /dev/video0 exists however, and that the permissions are correct.

Thank you for your reply.

I managed to make it work through the command line. I installed mpv and accessed the stream with :

mpv tv:// --tv-device=/dev/video0 --tv-width=960 --tv-height=544

It is not the best solution but it works !
If anyone has an idea on how to execute something similar from the osmc ui it would be great.

Did you try chown osmc:osmc /dev/video0 first?

I just tried and it didn’t change anything. I am still unable to play the .strm file linking to /dev/video0

A log would help

I will post a log when I get back home.
Meanwhile, I managed to make it work using mpv as an external player (External players - Official Kodi Wiki). It opens my .strm file and plays the stream

So that’s what happens when I try to play my TEST.strm file with /dev/video0 in it. It works if I open it using mpv as an external player which is fine for me at the moment.

LOG
2019-11-03 16:10:18.801 T:1879036640 ERROR: CAESinkALSA::Initialize - failed to initialize device “@”
2019-11-03 16:10:18.812 T:1879036640 ERROR: Previous line repeats 1 times.
2019-11-03 16:10:18.812 T:1879036640 ERROR: CActiveAESink::OpenSink - no sink was returned
2019-11-03 16:10:32.916 T:1915844144 NOTICE: VideoPlayer::OpenFile: /media/DIPLODOCUS/TEST.strm
2019-11-03 16:10:32.917 T:754905824 NOTICE: Creating InputStream
2019-11-03 16:10:33.007 T:754905824 NOTICE: Creating Demuxer
2019-11-03 16:10:33.007 T:754905824 ERROR: Open - error probing input format, /dev/video0
2019-11-03 16:10:33.007 T:754905824 ERROR: OpenDemuxStream - Error creating demuxer
2019-11-03 16:10:33.007 T:754905824 NOTICE: CVideoPlayer::OnExit()
2019-11-03 16:10:33.175 T:1915844144 NOTICE: CVideoPlayer::CloseFile()
2019-11-03 16:10:33.175 T:1915844144 NOTICE: VideoPlayer: waiting for threads to exit
2019-11-03 16:10:33.175 T:1915844144 NOTICE: VideoPlayer: finished waiting