Please Standby Boot Loop on Vero4K when USB disks are connected


I just received the Vero4k and I’m migrating config from my existng raspberry pi OSMC installation.

I have a USB hub with several things plugged into it, when the hub is plugged in and Vero reboots it goes into a Please Standby OSMC Logo loop until I remove the offending usb cable on the Hub.

The USB device that causes the loop is a 4 slot Hard Drive dock on which I have 4 Hard disk plugged into it so the all those HDs are directly attached to Vero4K (previously Rpi).

I had no issue with the Rpi booting but on vero4k I have to turn off the 4 HD dock while vero4k is booting and turn it back on when the booting process has passed the standby screen.

Can anyone advice on how to proceed to rectify this and avoiding having to turn off the USB Hard Disks every time that I boot Vero.

My DVB-T is also not being recognised for some reason but that’s a different issue which I can raise separetely after some investigation.

Thanks for any help in advance.

Is the dock a powered hub? For four disks you will need to externally power them.

A user had a problem with booting with some disks attached. We found the problem to occur with Seagate disks. After contacting them they have advised that a firmware update is available to resolve this problem.

Next month I plan to deliver a bootloader update to address the problem for those that cannot update their disk or peripheral’s firmware


Hi Sam,

Thanks for getting back to me.

The dock is externally powered and I have 4x 3.5" disks:

Disks attached are:
1x SAMSUNG HD103SI (This is the odd one I’ll try remove it)


Can you check if they have made a firmware update available?
Should have a workaround in next month anyway


Actually I’ve tried removing all disks one by one starting from the Samsung One.

What I found is that the issue is not so much the disk but the fact that as long as there is more than one disk plugged in to the dock when I reboot Vero the box goes on the standby loop indefinitely. With a single disk in any numbered slot the issue does not occur and vero boots normally.

If i turn the dock off and let vero come out of the boot loop and then I turn it back on I have no problem (meaning post boot all disks are seen normally)

1 Like

Yes, that means the dock is doing some ‘interesting’ things with halted endpoints.
The fix is rather simple, but I need to work on a reliable delivery mechanism for OTA bootloader updates.

It is on the list.
For now – keep the Vero 4K on as it’s not meant to really be powered off (it’s an always on device).


It is always on anyway.

It is just annoying if I reboot the device remotely via VPN for any reason as it won’t come back up and i’m not around to power cycle it, but once configured as I want it and assuming it doesn’t freeze and needs to be reset it shouldn’t be much of a problem.

At the moment I’m facing an issue with TVheadend as well:

osmc@Vero4K:~$ dmesg | grep -E "DVB|Real" 
[    3.665565] usb 1-2.3: Manufacturer: Realtek
[    4.506865] usb 1-2.3: dvb_usb_v2: found a 'Realtek RTL2832U reference design' in warm state
[    4.569569] dvbdev: DVB: registering new adapter (Realtek RTL2832U reference design)
[    4.599572] rtl2832 1-0010: Realtek RTL2832 successfully attached
[    4.599593] usb 1-2.3: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[    4.599609] dvbdev: dvb_create_media_entity: media entity 'Realtek RTL2832 (DVB-T)' registered.
[    4.643195] rtl2832_sdr Realtek RTL2832 SDR attached

I tried the package that comes in the store as it is now the version I need 4.2.2 as well as same package version I compiled on the Rpi but doesn’t make a difference really, Tvheadend doesn’t see it under “TV adapters”

I should probably raise it as another post though, it used to work find on Rpi.

The Vero 4K won’t freeze. At least it shouldn’t. If it does – then start a post and we will look in to it. With that said, a fix will happen soon enough, but I’ve also contacted the manufacturer to let them know about the issue.

DVB is in a state of flux on Vero 4K at the moment.
Does firmware get loaded? That would be the first step for detection.

I’ll have most adapters working in tomorrow’s update.


I updated today neither the boot or DVB-T issue were fixed unforutnately.

In answer to your question the adapter is being seen but something doesn’t look right considering the error:

osmc@Vero4K:~$ dmesg | grep -E "Real|2832|28xx|[rR][tT][lL]|1-2.3"
[    3.623817] usb 1-2.3: new high-speed USB device number 4 using xhci-hcd
[    3.735141] usb 1-2.3: New USB device found, idVendor=0bda, idProduct=2838
[    3.735152] usb 1-2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.735158] usb 1-2.3: Product: RTL2838UHIDIR
[    3.735163] usb 1-2.3: Manufacturer: Realtek
[    3.735168] usb 1-2.3: SerialNumber: 00000001
[    4.639507] usb 1-2.3: dvb_usb_v2: found a 'Realtek RTL2832U reference design' in warm state
[    4.693405] usb 1-2.3: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[    4.693437] dvbdev: DVB: registering new adapter (Realtek RTL2832U reference design)
[    4.693446] usb 1-2.3: media controller created
[    4.702753] rtl2832 1-0010: Realtek RTL2832 successfully attached
[    4.702776] usb 1-2.3: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
[    4.702791] dvbdev: dvb_create_media_entity: media entity 'Realtek RTL2832 (DVB-T)' registered.
[    4.746519] rtl2832_sdr Registered as swradio0
[    4.746531] rtl2832_sdr Realtek RTL2832 SDR attached
[    4.746536] rtl2832_sdr SDR API is still slightly experimental and functionality changes may follow
[    4.767437] dvb_usb_rtl28xxu: probe of 1-2.3:1.0 failed with error -22
[    4.767532] usbcore: registered new interface driver dvb_usb_rtl28xxu


As per the release notes, a fix wasn’t noted for either.
I needed further information from you to resolve the DVB issue and have already advised that while there is a workaround for faulty USB devices; a fix wouldn’t make it in to the September update.

I think you might be missing firmware here.

Hi Sam, didn’t expect the boot issue to be fixed as you pointed out it will take time to plan deploying your fix, shouldn’t have mentioned it in the comment it’s not like it’ll suddenly magically start working :slightly_smiling_face: you are right.

I missunderstood you about the TV adapter I guess when you said:

Initially on the rasperry pi I had the same issue with this adapter, and I think I added it manually in a folder somwhere before it got included in osmc.
Is there a way to install the firmware as a standalone file as I believe I did in the past before it was fully integrated in OSMC?


You can drop firmware into /lib/firmware if it’s missing.
If you let me know which firmware file was absent, I will include this
in a future update


I’ve compared the /lib/firmware folder content with the one I had on my RPI installation and I can’t see many difference (especially on the RTL files)

This is the specific device I have

osmc@Vero4K:~$ lsusb | grep RTL
Bus 001 Device 009: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T

I should probably not try to install it in the kernel header like indicated in this older post, should I?

Can you post dmesg with it attached on Pi?
And then dmesg on Vero 4K?



this is the Pi dmesg

this is Vero dmesg


Thanks, we anticipate having a solution to this problem shortly.


Thanks Sam, which one the TV adapter or the boot loop issue when usb dock with multiple drives are conneted?

There’s an issue with halted endpoints not being handled correctly by the bootloader. This would fix both issues; if that is indeed the problem.


1 Like

let me know if you want me to test it before deplying the fix if you have an easy way I can test it out for you.

If no consequence and you’ll send it out to everybody I’ll test it then.


Currently we need to work on a way to deliver bootloader updates reliably OTA. So it will be a little while yet before testing can be made available.