Poor Video Performance

I have an original RP1 B (not B+ if that matters) and I had XMBC and Kodi (Rasbmc) loaded on all three pi’s I own. I am running a Synology NAS with all data, databases and thumbnails on that NAS via NFS. I had no issues running any videos on the Rasmbc installs. Recently I reloaded one of them with OSMC and almost all videos are almost unplayable. They vary though, I could have one of my kids Disney TV shows and you can see a little choppiness and sometimes the sound is out of sync with the video but they wouldn’t notice as it is very slight. However if I play a DVD rip of, for instance, The Matrix…it is unplayable. Completely choppy and sound is way out of sync. What gets me is I have a rip of a Blu Ray and it plays %100 fine except for slight buffering at the very beginning before the show even starts. Again, Rasbmc with XMBC or Kodi running it did not do this. It seems to be CPU related. When I overclock the CPU the kids Disney shows are almost fine but still no difference on the DVD rip and the Blu Ray rip is fine whether I overclock or not. All of these files are MKV files. Any help would be greatly appreciated as I really don’t want to have to buy 3 new RPI3’s although I may buy one to see how much of a difference they make.

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

I’ll try and gather addtional information but here is mediainfo from one of the mkv files that is very bad.


The codec is MPEG-2. Have you got the MPEG-2 codec licence?

FYI - I have no add-ons or peripherals installed as this is a fresh OSMC/Kodi and both are the latest versions as of this post.

Yes, I thought the video wouldn’t even play if I didn’t have a license?

In the old days, this was the case. Now, Pi will try and decode it in software. If you purchase the license, your issue should be remedied.


Yeah hold everything. :slight_smile: I bought two licenses but I accidentally saved the same email (as a file) twice and I am missing the second license. Not realizing this (since I copied and pasted) I used the same license number on both Pi’s so one is working and the other is not. I’ve emailed the raspberrypistore to see if they can send me the licenses again. It was from back in 2013 so who knows. It’s only a couple bucks so I’ll buy it again if necessary. Sorry for the post when it was something so obvious.

If you paid for both licenses, and have a PayPal transaction ID of this, I’m sure you’ll be OK. I’d assume the email would contain all licenses though, so check you did purchase MPEG2 & VC1 first.

These two licenses were purchased a couple months apart after I purchased the 2nd of the 3 Pi’s so there were two emails. However, now that I look at it, I did not save the same email twice. The date on the emails are definitely a few months apart but the code in the email is exactly the same. I know this is probably no longer an OSMC support case issue but this doesn’t make sense. Why would the codes be the same? Both of these Pi’s were definitely working fine with MPEG2 files before reloading them with OSMC.

As for raspberrypi store, I still have my login and the two purchases are still showing. I emailed them with both order numbers asking if they can resend the codes but not sure that’s going to fix anything now that i see I do still have both emails…just the codes (keys) are identical.

Also, I did not purchase the VC1 license. I believe, at the time, I would not have any media files that required this license so I didn’t purchase.

I see. By duplicate key I thought you meant you received the same key for both licenses, not both devices.

Unfortunately this is out of our remit but I’m sure things will be put right.

However, if you received the same key twice, I suspect you may have accidentally sent the same Pi serial number twice.


The thing is, both devices were playing MPEG2 files fine. I would have definitely known if it wasn’t because we watched MPEG2 files in both locations all the time. Back when they were purchased (late 2013) I would have also known because I remember distinctly the video wouldn’t play at all.

Either way, yeah I agree this is out of this support’s realm but thanks for helping me. If it weren’t for the fact that the video was playing I would have instantly looked at the license. It’s only a $2-3, I may just buy another license anyway. I am curious as to why both licenses were identical though and how it worked prior on both devices. May never find out though. Thanks again.