Portable Hard Drive - Mounting


I have OSMC RC3 installed on my Raspberry PI 2 and it won’t mount my Portable Hard Drive (NTFS).
I tried another Portable Hard Drive (exFAT) and it won’t mount either.
I tried with my USB Stick (FAT32) and this time it worked.

How can I make it work for NTFS?

Thank you.

How is power provided to these drives that fail to be recognized? Have you noticed a small multicolored square in the top right corner at any time? Have you tried connecting them to the pi with a powered USB hub? Have you tried enabling max_USB_current in MyOSMC>PiConfig?

The enabling max_USB_current in MyOSMC worked. Thank you very much. Now I have a different weird problem. I opened my .mkv video and everything works fine, except it won’t produce voice sound. Strangely I can hear every other type of sound from the video except voice sound. This happens in every video from my drive. Any idea?

Thank You!

Did you change audio output to something other than 2.0?

You’re the best. Thank you!! :grinning:

Hi, I’m trying to mount a buffalo mini station to my pi 2 via osmc. When I plug the hard drive it starts to bleep and flash, I was wondering if this was a power problem, the unit doesn’t have a separate power supply, was reading yourbpost and it sounded like you had the same problem and may be able to help me through it,I don’t have much computing knowledge

Have you tried the max_usb_current option mentioned above ? If you have and it still keeps beeping/clicking there is no enough power to run the drive so you may need to get a power adaptor for the drive.

No ihavnt tried that yet, do I do it on the command line in osmc (after reboot and escape.??

Use the GUI… it’s in My OSMC > PiConfig

Thanks for that, the hard drive is now on but I can’t find it when it is connected?

It’s in /media

Where do i find the media file, I can’t seem to find directory?

Sorry about my knowledge,( or lack off it

Either Root Filesystem > /media


Home > /Media

Cheers will try it tomorrow

I have the same problem but I have no luck. Even the small colored shape in the connor is gone, the HDD is still not mounted

Most of the times, the cause is lack of sufficient power to the USB powered HDD.

I too had similar issues earlier and it was worse if the power to the device was not stable which caused problems while mounting or during browsing the folders or playback.

I then got a USB powered Hub and I don’t have any of these problem now.

I have a WD Elements 320gb drive in NTFS and, tried connecting to my OSMC Pi3 and doesn’t load up. But the same drive in FAT32 format works fine. Tried out a flash drive in NTFS format and loads up fine. I didn’t have the max_usb_current option in PiConfig either, went on to th config editor and added the variable setting it to 1. Restarted the OSMC and still no luck.
It’s my first attempt with a Raspberry Pi. Please help. TIA guys…

Check the cluster size of the NTFS file system. If it is > 32KB it will not work. Perhaps you can paste here the output of chkdsk /f g: when mounted on Windows, g: is just an example and should be the real drive letter.

It is also important to understand whether this portable hard drive has an MBR or GPT partition table, so connect it to Windows and invoke in a command window:

DISKPART> list disk

The column on the right should tell you whether this is a GPT partition table which might not work with Debian. There is a convert mbr command in diskpart for non-removable devices.