Possible PVR/Tvheadend problem

I saw this on both Pi and the Vero. Happens now and then, after reboot. There is a message “Loading guide from database, followed by a channel name”

It then hangs forever. Onle way out is to bounce tvheadend (4.0.7) and then OSMC. Seems that something gets stuck and never times out. How fo we troubleshoot?

Another problem, dunno of related is that when you page through recordings, using the arrow key, the underlying list jumps around, ie when paging up from one item you expect to se the selection jump to the next in the list, it does, but all the items change underneath, you also cannot move upwards past the third item from the top.

Reboot fixes it.


To troubleshoot, we will need logs showing these issues.

If you are seeing the issues across multiple devices, you may have more success with the kodi forums.

More than happy to try and help resolve, I just think your may have more success over at kodi.

Thanks Tom.

Ok. I will try logs next time it happens, but usually it happens as you are about to watch something and then mucking with logs creates a “wife acceptance problem”

I think you can send the logs anyway (you don’t have to wait for it to happen again).

The EPG issue, where multiple lines are highlighted - has been reported already. But is not yet
resolved. I find if you keep scrolling, it will kinda fix itself.

Do you have TVH and OSMC on the same machine? I have TVH on one Vero4K, and
OSMC on another Vero4K. It is very stable, very fast, very reliable. In my experience,
TVH works well if you set it up - and leave it alone :slight_smile: Having it on a dedicated machine
means, I don’t touch it, and it ‘just works’.

Best regards,

Yes. I run tvh on a separate (OpenSuse) box in the basement. This is for several resons actually. One is that it is noisy, fans and disks create noise (I have three Tb disks for storage). I also have four tuner sticks. Other reason is that I can bounce OSMC without interrupting recordings.

Not sure if we are talking about the same thing thoigh. I was referring to the list of redordings you see when you select “PVR” then left arrow and “recordings”

@anbodearg Loag uploaded apulaxjoh

Sorry, I was thinking of a different error.

I haven’t noticed that issue on the list of recordings, but I will take a look on mine tonight.
There’s a setting in TVH for how recordings are grouped - checkboxes to group a
recording based on title, etc.

Also, have you tried a different skin? For UI issues, I think it’s a good idea to first
check if it happens in the standard Kodi skin.

You mean “confluence”? I use the standard OSMC skin.

sorry, what’s the full URL?
I tried a few combinations, but I just get this: {“message”:“Document not found.”}

Is one character too short.

1 Like

Odd… Must have missed something when I jotted it down. I will be more careful in the future.

Ok, a couple of things …

I’m using TVH 4.0.9 on OSMC (Vero4K). I see you have a slightly earlier version (4.0.7) running on OpenSuse.
If it hangs, do you need to powercycle Vero4K and TVH…? I’m guessing it’s a TVH problem, where it is not responding for some reason to the TVH client on Vero4K.
If that’s the case, then probably the Vero4K logs will just show ‘no response’ from TVH.
It could be a mismatch between the TVH client on Vero4K and the TVH server … as they are two different versions.
TVH has debugging logs, so you could turn this on (from the browser), and when it happens again you might see something helpful there.
Also, it has never happened me … so might be an idea to upgrade your TVH server 4.0.9.

For the recordings, I can’t reproduce that paging/scrolling issue.
I’m using Kodi skin (estuary). But I also tried with the OSMC skin, and working fine there too.

My suggestion is to update TVH, and then see if the issues remain.


Best regards,

Yes. IIRC did I pull 4.0.9, compiled and tested a year back, but never completed the upgrade because of issues with one tuner. Did not want to change more than one thing at a time. Will continue down that road.