PowerShell 6 on Vero 4k +?

Hello there, is it possible (would it be somehow possible) to install pwsh on vero 4k ? I’m bit struggling with bash/Linux. :). https://docs.microsoft.com/en-us/powershell/scripting/setup/installing-powershell-core-on-linux?view=powershell-6

Just tried nd followed the instructions here:

It’s running on my vero4k, just don’t know how to handle it =)

Ah, Raspbian it is … Let me try :slight_smile:

Ah! What relief

Btw. here is correct how to https://docs.microsoft.com/en-us/powershell/scripting/setup/installing-powershell-core-on-linux?view=powershell-6#debian-9 (since Vero is running debian9)

Edit: Actually it’s wrong :). Sorry, my bad. Use Raspbian howto

Did you actually use those instructions?

The only Debian 9 package I could find is for amd64 architecture. The Vero4K and Raspberry Pi use armhf architecture, which is why @joakim_s tried the Raspbian version, since it’s labelled as being for “arm32”. Running amd64 code on a Vero4K won’t work.

Weird, Steps for Debian 9 worked for me.

Edit: of course you are right. I did not notice that package was not found. And pwsh was executing as I did not delete properly the powershell packages I installed with Raspbian howto

That is indeed weird, since the Debian 9 instructions contain the line

sudo sh -c 'echo "deb [arch=amd64] https://packages.microsoft.com/repos/microsoft-debian-stretch-prod stretch main" > /etc/apt/sources.list.d/microsoft.list'

[arch=amd64] is the issue here.