Problem after 2 hours Raspberry 2 remains suspended

I have a raspberry 2 last updated OSMC and kernel, from every two hours approximate thing two months ago when I enter into a menu or leave the raspberry is stuck
In the log the last thing is put
NOTICE: SpawnThread - fatal error creating thread

What can i do?

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Absent any other information, lets guess that the problem is your power supply.

As Karnage wrote provide full debug logs. Also check your power supply and cables can support the device well.

my power supply is 5v 2A is correct ?
is the same that 3 months before
and worked well
I´m recording the log

My log

Thanks for help

This is only the Kodi log, suggests you upload all logs

Enable debugging and thought this was the record
ok what can i do ?

In MYOSMC log uploader choose all logs.
Or if you want to make it easier ssh into the box and use grab-logs -A

It’s possible that is this

Yes, perfect

the power supply is correct ? or i need another one ?

What are you using.?

my power supply? 5v 2A

Are you using CEC to control your Pi?
Could you for a test disable CEC and use something else to control (e.g. Yatse on Android phone)?

Yes i use a CEC control of my tv samsung ,
But i try without CEC and fails too
I try with a new installation without nothing installed and about 2 hours fails too

I dont know what i do
I’m thinking of buying this
enter link description here

I would suggest that you buy an official raspberry power supply e…g. From Sam
But a Kodi freeze alone may not be power related. How do you recover it when it freezes?

when Kodi freeze i recover with reboot the system quit the power supply or
for SSH with: sudo sytemctl restart mediacenter , because SSH works .
But in the screen dont work nothing

So means the clock also doesn’t continue to count?

But if a sudo systemctl restart mediacenter fixes the problem I would not suspect the power supply as the main culprit (it still could be).
Could you try a clean install on a different SD card?

Yes the clock was stopped in the time that raspberry fails
I tried with one new SD card samsung evo 16GB and fails too
and with one SD card Kingston class 10 with 8 GB and fails too
Could i can try with a OSMC in USB ? or not

Would not recommend that, as you have tested several SD cards I would exclude the storage as an issue.
So you are using a plain new install without any addons added? And have you tried with CEC fully disabled?
Have you tried another HDMO cable?
Maybe new power supply is worth a test.