Problem after December update

on raspberry pi 1 B, I have black screen after installing the december update. No luck with a forced reboot.
I had to restore a DD backup.
It seems that it’s unable to find the boot partition when I turn on the raspberry pi. Here is my install.log: Thu Jan 1 00:00:12 1970 Starting OSMC installerThu Jan 1 00:00:25 1970 Detecti -

If you’re having an issue after restoring a backup, it means the backup was incomplete. You need to take a full, block level backup rather than a partition / volume based one.

You will need to reinstall.

Thank you for your very fast reply, Sam.
I didn’t explain well.
I was able to restore my dd backup and it works very well.
After that, every time I try to update to december release, OSMC download and install it but I have black screen on reboot.


I posted to another thread already, but I realized I have the same problem as described above:

After the update completed succesfully, OSMC splash screen appeared. After that only black screen is visible, although ssh is ok. The host is a raspi 1. Any idea?

Thank you.

If you still can access via ssh provide full logs by issuing grab-logs -A and post the URL here.
On the other hand as some one in another thread reported maybe unplug/replug the HDMI or full power down the TV and see if it helps.

If SSH is OK you do not have the same problem and you should have started your own thread.


Yes, I confirm that ssh isn’t working in my case.
I can’t see anything on raspberry pi boot. Only black screen.

I have to say that the only modifications that I did in your OSMC system are:

  1. I’ve add my NFS share of my NAS in fstab
  2. I’ve upgraded python to install youtube-uploader

Do you have any suggestions?

On power up do the leds flash? how many flashes? If you put your sd card in another PC can you read the boot partition? Try doing a scandisk on the partition.

I’ll let you know as soon as I’ll come back home.

Yesterday I tried to read it on my mac but I was able to read only the FAT partition.
Today I’ll try to read it with a linux machine (the boot partition is ext, isn’t it?)

Please, consider that I tried the upgrade twice (after restoring my backyp) and both time it was not able to boot.

The fat partition is the boot partition. If install failed twice have you tried a different sd card? The leds will flash error codes sometimes if there are problems reading the kernel. What revision of Pi do you have? Is the FAT partition full? If you do mount the sd in Linux run fsck on both partitions but failure to get any screen output sounds like a boot partition problem.

Just now noticed that you tried to update from a backup twice, have you tried a fresh install at all? You can restore your .xbmc partition from your backup to get your settings back after a clean install.

I start to reply to some questions… I’ll complete when I’ll come back home.


Raspberry PI 1 B (512mb)
The FAT partition is not full. It is plenty of free space.

Have you seen my install.log on pastebin?

You must provide the URL for the log.

It’s on my first post: Thu Jan 1 00:00:12 1970 Starting OSMC installerThu Jan 1 00:00:25 1970 Detecti -

Yeah I saw it earlier, unfortunately it doesn’t help much

1 Like