Problem Browsing SMB shares


When I try to add and SMB source by browsing I cannot see any other SMB hosts let alone shares. This only happens on my Pi which I updated to the latest version on Saturday. I wiped my SD card and installed from scratch.

My other Kodi devices such as my laptop and android TV all work perfectly.

All my shares are hosted on my NAS. I have my library on a MySQL db which is also on my NAS and works fine.

I have tried adding the shares manually by typing the patch using both the hostname and the IP address but I just get a message saying Error Connection Timed out back immediately.

All my network settings are fine.

Any ideas would be great as I have bene scratching my head furiously for a few days now and its getting very sore!


logs would be good. How to submit a useful support request - General - OSMC

I had the same problem, and after looking around, it would seem that the SMB-server is running SMB1, and OSMC has SMB2 as it lowest accepted protocol.

You can fix this by changing the client min protocol from SMB2 to SMB1 in .smb/smb.conf

Or get your SMB-server up2date. Take your pick.

EDIT: Some norwegian words had sneaked themselves in >.<

Perfect! Thanks for your help. All sorted now!

@Swoofah @tanner76 in the latest Kodi this has changed and now max protocol can now be limited via the GUI. Would appreciate if you could test that. Remove your entry from .smb/smb.conf and then set SMB1 as max protocol via Settings → Services → SMB-Client → Max Protocol