Problem with cec

Since update cec is not working as it was
Is there any way of uninstalling it?
Even when I turn off all the actions it is still switching the tv on in the night even though i have made sure all was switched off
It has stopped switching on the av
Before the last update it was working as it should, no matter which remote was used all came on at same time
Read a post on here last yesterday regarding similar issues and tried rebooting a couple of times but has not worked for me so would rather just get rid

If you turn off the first option “enable” then it should stop communicating with the CEC. If the issue is with some other device, likely the TV, and it having some kind of odd interaction then you may also have to also go into the settings on other devices (probably the TV) and disable CEC there as well.

Which version did you update from?
We haven’t changed CEC for a few months.

Have you tried turning everything off at the mains for five minutes?


Hi Sam,

Maybe a lead

I’m still on October update, but on my Sony TV CEC failed too. I was able to get it back but it disappeared at the end. Searching with the below error (with “cec-client -r”)

unhandled response received: opcode=84 initiator=1 destination=f response=1

I’ve found but I need to test the scenario

An answer to the above questions would be useful, as there were only changes about five months ago.

The issue you’re referencing is quite old, so I’m sure that the issue would have been remedied by now.

You’re right Sam my issue has nothing to do with OSMC. I updated/tested a lot this morning and the root cause is another HDMI device recently added. Disconnect it and restart the TV gives me the CEC entry back displayed and functional. Restarting the TV when this HDMI device is connected create the issue: no more CEC entry in the external input and CEC not functional. Weird, need to investigate it but definitely not and OSMC problem.

It might be useful to others if you could specify the other device that creates the problem?

Indeed. The device is specific to a TV provider in my country however the solution is more generic for such behavior.

My problematic device: TV box Evasion (specific to Belgian market)

Behavior: new HDMI device connected and no more ARC sound on your AV (or no auto ON/OFF with your TV), CEC issue with remote, etc. Once the device is disconnected (HDMI) and CEC handshake done again (all devices OFF then ON is the easiest) the problem is gone

Solution: I met this issue already with a soundbar so once identified and if the device offers no option to control CEC (not supported or function blocked) simply add on its HDMI cable an adapter blocking the 13rd pin (CEC signal).
This one works

Thanks sam sorry didn’t get back to you sooner
It seems to have sorted itself out after resetting tv and amp all now seems good

1 Like