Problem with HTSP TVheadend plugin

Hello
After change of router and restart of raspberry I can´t see in Main menu Television item.
However I can login to tvheadend over web pages and I can program for recording any movie over web interface, but I can´t programing anything over HTSP interface.
Do you have some idea how to repair it?
My logs is here.
http://paste.osmc.tv/iyelofomuv
Raspberry Pi3, Noobs, OSMC last version

Thanks
Jan

11:43:51.079 T:1483731712   ERROR: AddOnLog: Tvheadend HTSP Client: pvr.hts - unable to connect to 192.168.100.9:9982

Check your IPs as when you installed the new router IPs may have changed.

Also before going to much further, you are going to need to remove the banned addons.

This IP is correct. Its my RPi3.
Which banned addon you mean?
Actually I have installed only Youtube and NASA addon from Kodi repository and a few plugins from Kodi CZ SK Repository.
Jan

Read: Official:Forum rules/Banned add-ons - Official Kodi Wiki

OK
I think I have no any installed addon from blacklisted addons or repositories or I missed something?

Yes, you are missing something. If I tell you straight out, I’d have to hide this post, so I’m giving you a chance to fix it without me doing that.

OK
I don´t know what you mean, so I uninstalled all my video addon and situation is same.
Here is my new logs:
http://paste.osmc.tv/edudetihuv
Jan

You still didn’t fix your sources.xml, but it looks like you did get rid of the other junk.

I’m not real familiar with THV, but I keep seeing this error in your logs:

00:54:38.536 T:1436283648   ERROR: SQL: [TV29.db] Abort due to constraint violation
                                        Query: INSERT INTO channels (iUniqueId, bIsRadio, bIsHidden, bIsUserSetIcon, bIsUserSetName, bIsLocked, sIconPath, sChannelName, bIsVirtual, bEPGEnabled, sEPGScraper, iLastWatched, iClientId, idEpg) VALUES (1946312449, 0, 0, 0, 0, 0, 'http://osmc:osmc@192.168.100.9:9981/imagecache/147', 'HOBBY TV', 0, 1, 'client', 0, 2146250725, -1)
00:54:38.536 T:1436283648   ERROR: CommitInsertQueries - failed to execute queries
00:54:38.551 T:1436283648   ERROR: SQL: [TV29.db] Abort due to constraint violation

You might try starting with a new TV29.db.

sudo systemctl stop mediacenter
mv .kodi/userdata/TV29.db .kodi/userdata/TV29.db.save
sudo systemctl start mediacenter

and reconfigure TVH.

osmc@osmc:~$ mv .kodi/userdata/TV29.db .kodi/userdata/TV29.db.save
mv: cannot stat ‘.kodi/userdata/TV29.db’: No such file or directory

There is no any TV29.db in userdata directory and after reconfiguration of tvheadend (checking of configuration) it was same.

Sorry, since I don’t have TVH, I was guessing, but the search feature on forum can help. Try this instead:

mv ~/.kodi/userdata/Database/TV29.db ~/.kodi/userdata/Database/TV29.db.save

Ok
It was helped
After a few restart and kodi freezing now the htsp interface running. No any reconfiguration was necessary.
The file TV29.db is a file for TVH or HTSP? Just for increasing of my knowlegdes.
:slight_smile:

Thank for your big help

JanS
P.S. Which addon I missed?

I don’t think it’s specific to TVH, as I noticed I have it.

Look at your sources.xml, and read the post that I originally linked and you will see the banned repo that you have.

While I do understand that you trying to avoid any connection with piracy I do think that refusing to help people just because they have a “bad” addon installed ( and they are not even seeking help for that addon ) is a bit backwards to not say something worse specially considering kodi and vero are aimed at playing media in file format… which you know as well as I do basically means that people would need to rip their own discs. Wich can be done with apps that are pretty gray area because they remove encryption and are meant for making “personal backups” (haha good joke). And even if I want to play the media I bought off itunes I can’t play it on vero without removing DRM and the app to do so is very ilegal.

I know you didn’t come up with the rules but it seems a bit backwards considering the circumstances

And just where did I refuse to help him? In fact I solved his problem for him! And those ‘bad’ addons are know to cause problems with the system overall, so requesting that he clean them up is perfectly legitimate.

If you mean **** - I have no any addons installed from this repo.
Anyway I already deleted this repository from my sources.xml.
Thanks again for your help
Jan

Yes, you got it, and there were add-ons installed from it. You removed them when you removed the video add-ons.

I´m little bit feeling like in the world of Harry Potter - “He who must not be named”

I removed all my video addons - including Youtube and NASA from Kodi repository, because you did not wrote the name of blacklisted addon and again - all of my addons was installed from Kodi Repository and repository with czech addons

The truth is, that I have from history in sources.xml some banned repository - but all of my installed addons was installed from different repository - I used this repository in the past for some testing, because there was some old version of addons from Kodi CZ SK repo.

I very much appreciate the hard work of the entire OSMC team - that’s why I use OSMC, but some things are hard to understand for me.

:smiley: The important thing is that your problem is solved, and your system is cleaned up. You can add back in the good stuff now :wink: