Problems since April update

Hi there,

I’ve been having a problem since updating to the latest (April) release on my Raspberry Pi 2. I updated from the command line using ‘apt-get dist-upgrade’.

My main problem is there is a noticeable reduction in video quality on channels streamed from my DVB-S2 tuner (TBS 6985) which is accessed over the network from my TVHeadend setup.

The picture is noticeably ‘jerky’ these days. What was formerly very smooth video (just like watching TV on any TV STB) now looks like it is missing frames. This is most noticeable on news channels where tickers no longer glide across the screen with ease. It just kind of looks like what should be 25 fps TV is running at about 15-20 fps.

The problem is present on SD and HD channels. This is on a setup configured to send 720p50 video over HDMI.
I have tried various combinations, to no avail.

Another problem is that GPIO IR sensor can now randomly stop responding and leave me without a remote.

I have tried formatting my SD card and starting with a fresh install, but the video has not returned to it’s pre-update quality. The GPIO does seem more stable now, however.

Is anybody, using OSMC for live tv, having similar problems? I am at a loss to work out where it all went wrong.
I am considering installing an earlier version, but would rather keep up to date.

Any her appreciated,


A debug log may help.
Try enabling “sync playback to display” in video/playback settings (or disable if it’s not enabled).
Try enabling “omxplayer” in video/acceleration settings (or disable if it’s not enabled).