Problems with Docker on raspberry pi 3

Hi. Today I decided to install everything from scratch again in my Raspberry pi 3. Install the latest version (image: OSMC_TGT_rbp2_20170705.img), configure the system, update (sudo apt-get update and dist-upgrade). When I want to install Docker, as I had in the SD before It throw the following error:

$ curl -sSL https://get.docker.com | sh

Either your platform is not easily detectable or is not supported by this
installer script.
Please visit the following URL for more detailed installation instructions:

https://docs.docker.com/engine/i…

Anyone know how to fix it?
Do I have to do something previously?
Thx in advance.

Thanks for posting after your Twitter message

Try sh -x to see what it says.
Also sudo sh -x is probably needed

with curl -sSL https://get.docker.com | sh -x

  • lsb_dist=
  • [ -r /etc/os-release ]
  • . /etc/os-release
  • PRETTY_NAME=Open Source Media Center
  • NAME=OSMC
  • VERSION=June 2017
  • VERSION_ID=2017.06-1
  • ID=osmc
  • ID_LIKE=debian
  • ANSI_COLOR=1;31
  • HOME_URL=http://www.osmc.tv
  • SUPPORT_URL=http://www.osmc.tv
  • BUG_REPORT_URL=http://www.osmc.tv
  • echo osmc
  • lsb_dist=osmc
  • echo osmc
  • lsb_dist=osmc
  • echo osmc
  • tr [:upper:] [:lower:]
  • lsb_dist=osmc
  • command_exists lsb_release
  • command -v lsb_release
  • [ -z ]
  • [ -r /etc/os-release ]
  • . /etc/os-release
  • PRETTY_NAME=Open Source Media Center
  • NAME=OSMC
  • VERSION=June 2017
  • VERSION_ID=2017.06-1
  • ID=osmc
  • ID_LIKE=debian
  • ANSI_COLOR=1;31
  • HOME_URL=http://www.osmc.tv
  • SUPPORT_URL=http://www.osmc.tv
  • BUG_REPORT_URL=http://www.osmc.tv
  • echo 2017.06-1
  • dist_version=2017.06-1
  • check_forked
  • command_exists lsb_release
  • command -v lsb_release
  • cat

Either your platform is not easily detectable or is not supported by this
installer script.
Please visit the following URL for more detailed installation instructions:

  • exit 1

That’s the issue.

curl the script and remove that check or get it to check /etc/os-release instead.
I’ll mention it to Docker guys shortly.

Sam

I did some digging in the docker-install.sh script, and “routed around” what I think was the problem (I think they have an IF;THEN;ELSE in the CHECK_FORKED method with incorrect FI placement. However… when the script then executes as a dist:DEBIAN version:JESSIE I still get an error when apt get tries to pull from the repository to install Docker:

> + sudo -E sh -c add-apt-repository "deb [arch=armhf] https://download.docker.com/linux/debian jessie edge"
> Traceback (most recent call last):
>   File "/usr/bin/add-apt-repository", line 167, in <module>
>     sp = SoftwareProperties(options=options)
>   File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 105, in __init__
>     self.reload_sourceslist()
>   File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 595, in reload_sourceslist
>     self.distro.get_sources(self.sourceslist)    
>   File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 89, in get_sources
>     (self.id, self.codename))
> aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Raspbian/jessie

It would seem that the OSMC apt system is expecting a Raspbian deb, not a Debian one. (I admit, I’m pretty new to the apt/Debian/Raspbian world, so I could be way off.) Any thoughts on how to proceed? The Docker install script carves out specifically for Raspbian; perhaps I should be following that versus the straight Debian case for RaspPI.

EDIT: I should add, I just realized that since I was running a Raspberry Pi Zero W the sources.list for that ARM A6 hardware does point to Raspbian. Maybe I just can’t run Docker on this kit!

EDIT2: YAY! Docker installed (I mod’d the os-release file, temporarily, to ID=raspbian) and Homebridge is running! I think the sigO is starting to get annoyed at the lamp going on and off and on and off and on and off… she’s calling Siri names.

@sam_nazarko, I can’t get curl -sSL https://get.docker.com/ | sh do work.
It used to work some weeks ago… :frowning:

Any clues on a fix?

Temporary fix:

sudo nano /etc/os-release
changed the ID=raspbian

1 Like

It would help if you told us which device you were using or even the output of that command.

Not aware of a reason for this issue. Does it work with an older version of OSMC?

Docker is usually better installed via APT

Pi3. Error message:

Redirecting…

osmc@osmc:~$ sudo curl -sSL https://get.docker.com/ | sh

Either your platform is not easily detectable or is not supported by this
installer script.
Please visit the following URL for more detailed installation instructions:

Redirecting…

It used to work before with this same version of OSMC. Using the official commands to install emby server: Forums - Emby Community

So the issue is caused by a change in the Docker script?

Hi. I was able to solve it. Following the instructions detailed in the following link

Right now I have Docker installed, sonarr, radarr, deluge, muximux, plex, portainer all in containers.

Thx for the response. I wait for the oficial fix. Thx again.

I’m not sure. As I said if i change the id=raspbian the script will work.

Same as @Diego_Karaski, editing /etc/os-release to temporarily change id=osmc to id=raspbian allows the install script to pass its checks and complete the install. (I did need to manually start the docker daemon after install though …)

Although this is a year old script, I thought I would add my input since I decided to switch from the hypriot .deb package to the official docker version/method.

Regards,

Are you using a Pi1 or Pi2?

Sam