Problems with OSMC WiFi dongle+RPi1

Hi all!
I recently bought a OSMC wifi dongle for my RPi1. I installed OSMC again, specifying that the new network would have been a WiFi network (and not LAN anymore) but WiFi dongle is not working properly: when i get into the interface to enable it, I set the checkbox to true but, after a while, it cannot detect any network and it is automatically disabled again.
I tried to work on it using SSH (connamnctl) and using “enable wifi” I can actually enable the interface, but “scan wifi” doesn’t give me any available connection.
Any suggestions?


Is your Power Supply up for the job?
Connect a LAN cable and provide logs with grab-logs -A

Hi fzinken, thanks for your quick reply.
I’m using an external power adapter (states that can provide up to 1.2A).
This is my log:


This is not enough especially when connecting USB Wifi Adapter. The RPi need a stable 2.5A powersupply like the official on from the store Raspberry Pi Power Supply 2.5A - OSMC

Which most likely is also the reason you get this errors

Jun 13 08:30:55 osmc kernel: usb 1-1.2: USB disconnect, device number 11
Jun 13 08:30:55 osmc kernel: rtusb_disconnect: unregister usbnet usb-20980000.usb-1.2
Jun 13 08:30:55 osmc kernel: RtmpOSNetDevDetach(): RtmpOSNetDeviceDetach(), dev->name=wlan0!
1 Like

Ok thank you, I will upgrade my PSU and i will let you know if it is solved
In the meanwhile, thanks again!