Python 3.5 doesnt see pandas library, but 3.4 does

I have installed pandas with “sudo apt-get install python3-pandas” on my RPI2
On this device, I have installed python 2.7, 3.4 and 3.5.

I noticed that I can use import pandas from python 3.4 prompt, but not from 3.5.

Have I done something wrong?

Check site-packages.

…and do what?

Except the fact that I can see pandas only in python 3.4, pandas version is 0.14.1, and with
sudo apt-get install python3-pandas
I can’t install more recent version.

What could be the problem?

The latest version of python3-pandas is Debian jessie is 0.14.1-2.

The version available in Debian stretch is 0.19.2-5.1.

Currently, OSMC is still using jessie.

Can I somehow install newest version?

Never mind as stretch is about to come I will just wait for a while. Thanks.

You can install it via pip

I tried, but with no success. :frowning:

That’s quite a big log but it does contain the line:

Successfully installed pandas python-dateutil pytz numpy six

so why do you think it failed?

Because, when I import pandas, its version is 0.14… instead of 0.20

Probably because the version included in Jessie is indeed 0.14.1-2 ?

Edit: Sorry, I didn’t see @dillthedog answer above. You could install it using sid’s repo, but it might bring up unwanted results.


Stab in the dark here but you could try:

sudo pip uninstall pandas


sudo pip install pandas==0.20


sudo pip install pandas==0.20.3

Thanks Tom.

It doesn’t work. :frowning:


What fails?

The installation of pandas==0.20?

Or can you still not import it?

Thanks Tom.