Rainbow at the top right

Dear friends,
When I use OSMC I see always a small box with a rainbow at the top right of the screen.

I see it even when I see movies.

Does anyone knows how to turn it off?

Its showing as it has detected your PSU is underpowering the Pi. I had this on my Pi2 despite the 2A Blackberry PSU having been used on the Pi B for a couple of years and was rock solid. If you aren’t experiencing any issues then add this to the /boot/config.txt to disable it;


Edit : Originally I was getting this warning on Alpha 4 but it seemed to go when RC1 was released. Although I have a feeling my early Pi2 is more sensitive to this than the later Pi2’s I purchased. It could just be my imagination though.

Edit 2 : You may get away with avoid_warnings=1 unless you are using turbo which is when you need the 2 I believe.

1 Like

I will try it.

Thank you very much!

It’s not a good advice to ignore such warning,you better recommend a stable and sufficient power supply.
The importance of a good power supply

1 Like

If you are not experiencing any issues other than seeing that warning on the screen then I don’t see any harm in disabling it. I disabled it and didn’t experience any issues.

Edit : To add to that, given I experienced this warning with A4 but not with RC1 then I expect the firmware was updated or RC1 is more efficient hence I’m glad I didn’t purchase another PSU.

1 Like

You can ignore it and even disable the warning,but such an indication is not shown just for nothing,my advice remains the same purchase a solid and stable power supply.

1 Like

I think it’s a good warning to have.

I’m running OSMC RC2 in a picture frame with an LCD screen from an old HP Pavilion laptop.
For power, I found a 5V output on the LCD controller board.
So I soldered 2 wires to a USB socket (5V, GND).
Then I just plug in the RPI using a regular USB cable.

This was working fine for a few weeks, but then the coloured square appeared.
So, I looked at the back of my picture frame and discovered that the GND wire had broken free.

What’s amazing is that the RPI and OSMC still worked! with just a 5V wire connected,
and a GND floating in mid-air…!

So, I re-soldered my GND wire, and now OSMC RC2 is perfect again.
With no more coloured square.

So, my advice: don’t disable the warning … you might be glad to have it someday :smile:

Dear anbodearg

Thank you for your answer.

I changed the power supply and I also received the rainbow.

The cable is a new one (and thick) that I bought and I cannot believe that there is a problem with the new cable.

I don’t know what’s wrong but the behavior is strange.

Thank you again,


You didn’t say what you had connected to your usb ports. If a usb hard drive for watching movies you may want to increase the current capability of the ports. I can’t recall if you there is an option to select this in OSMC, otherwise you could try adding :-


to your config.txt file.

EDIT: yes, if you go to Settings - Pi you can enable “max_usb_current”

Thank you pscriven

I did that and even without anything, just the Raspberry, I can see it.

Maybe I have a faulty device…

What else do you have plugged into the PI USB…?
Any devices esp HDD will use a lot of USB power. You need a powered USB hub for such devices.
(Answering this on my phone, so sorry if it’s not helpful)
Best regards,

Dear Niall,

Even when NOTHING is connected, I can see the rainbow box.

Thank you anyway.


sorry, I didn’t catch that the first time.
was reading this on my phone at the same time as minding three small kids :smile:

Do you have a multi-meter?
Can you measure the voltage difference across TP1 and TP2
It should be (from memory) more than 4.75 volts.

You didn’t mention which model of RPI. Also do you have
Wifi dongle or are you using ethernet wired connection?
Were you running RaspBMC previously with no problems?
or is this the first time with OSMC?

Are you using custom overclocking settings?
Did you change the overvolt setting?

1 Like

I don’t have a multi-meter.
I am using the Pi2
Don’t use any dongle, just the keyboard dongle.
The connection to the Internet is via RJ45

This is the first time I use OSMC.

But do not bother.

I can manage with that.

I just want to create a simple media center for my mother - Music, some videos and DVB-TV.

ok, what PSU are you using?
I have read before that phone chargers are not always suitable - because they supply a trickle
current - which is not the same as proper PSU.

For OSMC, I would suggest ordering an official RPI PSU 2A.
These are less than 10euro I believe.
Since it’s for your mother, you don’t want intermittent problems later - especially when you
start using DVB aswell.

If you still get coloured square with RPI PSU 2A, then I think you should return the RPi as faulty

I’m using an Ipad PSU and also a GP 2.1 A.

I think that maybe the unit is faulty.

Thank you,


Hi Ilan,

Not all power supplies are the same, as they have been built for different purposes. Incidentally I have ordered my RPi2 from ModMyPi in UK right when it came out, and I selected one power supply in particular for it: it’s the MMP-023. What’s particular about this is that it delivers 5.25 volts in idle, however under load the voltage drops to 5V - exactly how much the RPi needs. Other generic power supplies may deliver 5V in idle and light load, but under significant current the voltage would drop below this nominal value.

The quality of the cable is also very important; keep it as short as possible, so that the internal resistance of the cable wastes the least amount of energy (as heat). Some cheap cables don’t even have copper inside (which is one of the best electrical conductors), but iron - you can even pick them up with a magnet :smiley:

Funny you should mention that power adaptor from ModmyPi - I have 3 of them for my Pi’s and for my Pi B and B+ they have worked absolutely fine, but for my Pi 2 I kept intermittently seeing the low voltage warning in the top right on two of them and my oldest modmypi adaptor wouldn’t even boot the Pi 2 to Kodi at all.

I bought one of these official supplies for my Pi 2 and no more problems with low voltage.

So while I was previously recommending the ModmyPi 5.25v adaptor, since getting my Pi 2 and having this issue I now recommend this one…

1 Like

BTW, what country are you in…?

I read another post where the mains voltage (UK I think) was 240V, and no Rainbow.
But, then the same PSU in Spain (I think) where the mains voltage was 220V, the Rainbow

I doubt in your case that the RPI is faulty. If you get a replacement RPI and
still have the problem - I would say definitely you need to get official RPI PSU 2A

These power supplies are using a “chopper” to generate the output voltage, so the result is always a controlled value regardless of input voltage. The transformers used years ago, which had a fixed ratio between input and output, are long gone. You can check that the power supply is labeled to work universally, with input voltage between 100 and 240 volts, 50 or 60 Hz.

However, having a decent power supply, the next major factor is the cable - too thin, too long, not made of copper, with flimsy contacts, all these contribute to the delivery of an insufficient current from the power supply to the RPi. Unfortunately, too few cables have their AWG rating printed on them, so it’s a gamble.

If you have tried several different cables as well (different models/makes) and the issue persists, you should look for a warranty replacement of the RPi.