Raspberry/OSMC crashes

Hi,

since about a week or so OSMC keeps crashing every once in a while. I don’t know the reason for it. I haven’t made major changes to the system. If I turn my TV on, sometimes the screen just remains black. My Raspberry Pi is running though (LEDs on), only OSMC isn’t. I’m not able to connect to the Pi via WLAN either. Only thing I can do at that point is disconnecting and reconnecting the power supply. After that OSMC boots just fine and works as always, until it crashes again.

Any ideas?
I’m running OSMC with Arctic Zephyr Skin on a Raspberry Pi Mod. B Rev. 2.

Is this what you are calling a crash or are there more symptoms? If this is your problem you may be losing edid data when the TV is off. Go into MyOSMC>PiConfig>Display>Store HDMI to File and select it, reboot and see what happens

Thanks for the fast reply!
I’ll check when I’m at home. Thing is it doesn’t happen everytime I turn the TV off (or on), so I think that can’t be the reason.

So are you saying that it’s not a crash but is a blank screen when cycling the TV power intermittently?? People REALLY need to explain their problems concisely if they want help.

First, I’m not an OSMC or Pi expert, so neither do I know what’s the exact problem or what’s causing it, nor do I know if “crash” is the appropriate term here.
I’m saying it crashes, because not only the screen turns black, but also I can’t find the device in my LAN anymore (as I said in my initial post).
It never happened while I was actively using OSMC, so I can’t tell you if an error message shows up before it “crashes”. I only see that it crashed when I turn my TV on, or when I want to access it from my PC via (W)LAN.

Check your CEC settings in Settings->System->Input Devices->Peripherals and make sure you don’t have any of the options set that might try to shut down or suspend your Pi when the TV is turned off.

Also in Settings->System->Power Saving, make sure you do not have Shutdown function timer enabled.

If it would be shut down when TV is turned off, wouldn’t the Pi’s LEDs be off as well? And as I said, this doesn’t happen everytime. Sometimes I turn my TV on and OSMC is still running (which means that powering off my TV the last time didn’t power off OSMC too).

I don’t have such a timer enable.

No, because the Pi doesn’t have a hardware power off ability. If you shut down the operating system the power and red light will still be on, but it will be completely unresponsive - no picture, no response to the keyboard and you won’t be able to ping it. Turning the physical power off and on is the only way to boot again.

But did you check the CEC settings ?

Checked CEC settings:
nothing is checked, except the first two: “Enabled” and “Make Kodi the active source when starting”
other options are set to none or ignore

Btw. ALL the LEDs are on, not just two.

Just now I’ve seen OSMC crashing while I was navigating through the menus. I’ve only seen the last error message, which said something like “unsafe storage removal”. After that, the screen went black and I have to plug the power supply off and on again.

Unsafe device removal followed by a freeze is almost certainly an inadequate power supply.

Do you have an external hard drive connected that you are trying to power from the Pi ?

I’ve run my setup as is for about 1-2 years now. There were no changes hardware-wise and I’ve never faced any problem concering the power supply. I’m powering my Pi from an external power supply (not via USB port). My ext. HDDs are connected to a USB hub, which has it’s own power supply.
So I would be surprised if the power supply were the problem here.

Funny thing, I’ve got 2 lamps, one on each end of my sofa, one of the lamps stopped working. Someone said it could be a bad bulb but I can’t see how that’s possible as it has worked fine for the last 2 years.

Random unsafe device removal is not going to be a software problem, it will be a hardware issue, you can be sure of that.

It’s the Pi loosing contact with the USB device unexpectedly. It could be many things including:

  1. Low voltage to the Pi - the USB controller is the first thing to malfunction when the voltage is too low. This can be any combination of inadequate power supply, faulty power cable, too much overclock, excessive power drain from attached USB devices, or faulty poly fuse on the Pi and can be exacerbated by high CPU/GPU activity. Funnily enough total system freezes are also almost always due to low voltage caused by one of the above reasons.

  2. Faulty USB cables, faulty USB hub, faulty power adaptor for the USB hub (most USB hubs automatically revert to drawing power from the host USB device eg the Pi if their power adaptor stops working) or faulty hard drive.

To say that it can’t be a hardware problem just because it has always worked properly previously is just, well, silly. You’ve never had an electronic device fail on you or start to become unreliable with age ? I sure have…

If you look for a software solution to a hardware problem you won’t get far I’m afraid.

^Thank you!

An hour of my life I will never get back

Okay I’ll be blunt this was released far too soon and should have been released as a beta. You have put me in a sticky position of not having a media OS to put on my PI as this OSMC is not functioning in any way. Firstly the Sony Remote does not control the O.S. Secondly it does no recognise my wireless Microsoft Keyboard. I can only use it via a wired Keyboard ffs. - 1 Foot away. It is simply unusable!!! I only upgraded because the old Kodi version refused to reboot due to an update and found I could only get this faulty beta that is OSMC. I am not a computer whiz by any means and the old OS gave me what I needed. My PI has been officially bricked! What is worse it took me an hour of my life to put this on an SD, reinstall and try it which I will never get back.

Thanks for sharing…

Now if you would like some help see the stickies for a useful support request

1 Like

Everyone volunteers here in their spare time. Everyone replying to you is doing so now. Please afford them some respect.

I can understand your frustration, let’s go through things beat-by-beat.

There are a large number of users without issues. Why are you so convinced that there are unisolated and wide spread issues?

Are you talking about CEC? Try powering off the TV at the mains for 10 minutes. This can fix some CEC problems.

We support a lot of hardware, there’s sometimes an exception. Can you try another keyboard to see if the issue is the keyboard itself? I suspect you may have a power supply issue. You can learn more about the importance of a good power supply here:

https://osmc.tv/help/wiki/pi-power

Relax. It’s fine… Let us help you by giving us a better description of what’s wrong. If you can look here for information to help us solve issues, that would be great:

https://discourse.osmc.tv/t/how-to-obtain-provide-necessary-info-for-a-useful-support-request-includes-current-versions/5507

S

2 Likes

You are the sort of person who buys a raspberry pi, which is produced by a foundation that states its mission is to promote education, and then complains about a mere 1 hour spent installing free software (most of which was spent staring at a progress bar), finally claiming the software, of which you have absolutely no knowledge whatsoever, wasn’t at “release” quality, despite the forum obviously not being flooded with 400,000 other people complaining about the same thing.

Those are the facts.

Normally I would have a bit of fun responding to you with the same tone you used in your post. But in this case, the fact that you have to walk around this world being THAT guy shows that life has had enough fun at your expense already.

Day.

1 Like

many thanks for making me smile this morning. Reading your post has given me 1 minute of laughing and as laughing is healthy I believe I gained an “extra” hour of my life (sometime further down the road)