Raspberry Pi 1 512Mb unstable

First post here, so please forgive any mistakes.

I have tried to search my way to a solution, but haven’t found any.

For the last many many months I have run my Pi with the last RaspBMC release.
The system has been rock solid stable, would run for months on end without problems. Only reboots were due to power outages, or me cutting power during vacations and such.

Basically problem free, and running very well.

About 2 weeks ago I decided to upgrade to OSMC.
I figured it would be nice to get the latest updates, and new features.
But it has proven to be a mistake. I simply cant get the Pi to remain stable. It will crash. Sometimes after a few hours of uptime, sometimes after a few days.

Normally I find it frozen with a black screen, but sometimes it dies during playback, where at first the picture freezes, and after a few seconds so does the audio. Then the Pi is unresponsive.

I run it at standard clocks, non overclocked.

I have even tried underclocking without results.

I do like OSMC, it seems some videoes play back better, and its definately a more polished product than RaspBMC.

I must add that I have added my NFS share with my media as a network drive using this in FSTAB, as I find the network performance in this mode much superior.

172.26.1.8:/export/Media /mnt/media nfs vers=3,ro,nodev,nosuid,intr,x-systemd.automount 0 0

What could be my issue.
It could of course be the PSU, but the OSMC doesn’t show any warnings, and this PSU have kept the Pi stable for the last many months.

Please tell me what you guys think.

Logs are uploaded:

https://paste.osmc.tv/xaxiwejedi

Older Raspberry Pi devices won’t show warnings when there is undervoltage. The capability to check this was introduced with the Pi B+.

OSMC will use more power than Raspbmc. Your power supply may have been borderline before and you were quite lucky.

If you have peripherals attached to the Pi (USB); then removing these temporarily may give you enough power to proceed, but it’s not a proper solution.

Oh a reply from Sam himself :slight_smile:

Thanks.

It could off course be the PSU, I dont deny that.

I guess that is your main suspect?

It is an 5V / 2,5A PSU, connected directly through the GPIO socket and not the microUSB slot.
But it is off course a few years old.

I have access to brand new 5V / 4A PSU’s, I’ll try one of those if you think its worth it.

Yes – try another power supply.

OK.

Will get one tomorrow and report back here, when I have some results.

Edit:
Got the new PSU today instead, and have it installed now. The Pi is booted, and playing a movie right now.

Will report results in a few days, when I know if its stable.

Well your config.txt says
arm_freq=900

Which is overclocked (but supported) for a Pi1.
If the replacement of the power supply doesn’t solve the problem I would suggest to remove that for testing.

Thanks for pointing that out.

I will say, that even though the Pi might have run overclocked when I uploaded the logs, I have run it at both OSMC standard clocks, and “underclocked” (at both 750 and 800 Mhz), without it becoming stable.

As said I have now replaced the PSU, and time will tell if it has helped. I really hope so :slight_smile:

I also hope that it will be stable at the “High” overclock, as performance is definately better at that setting.

I’m guessing that the 2,5A PSU could have been borderline, as I boot from a 16GB USB3 stick, and have a infrared receiver hooked up to the other USB port. Both of these things use power, so it could be that the 2,5A unit was running at or beyond its capacity.

Or it was degraded as hardware is shown to do over time.

Well, today when I got home from work the Pi was dead again. When I switch to the Pi theres only a black screen, and it doesn’t react to the remote.
This morning before work it was still working.

I did a little experimenting.

As said, theres no picture from the Pi.

SSH doesn’t work.

I can ping the Pi though:

Pinging 172.26.1.7 with 32 bytes of data:
Reply from 172.26.1.7: bytes=32 time=3ms TTL=64
Reply from 172.26.1.7: bytes=32 time=1ms TTL=64
Reply from 172.26.1.7: bytes=32 time=2ms TTL=64
Reply from 172.26.1.7: bytes=32 time=1ms TTL=64

Ping statistics for 172.26.1.7:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)

So something is still alive…

I will try running it for some more days to see if I can find a pattern to this. I dont think its the PSU anymore.

Perhaps I should do a reinstall, even though the thought of that is not apealing :slight_smile:

You can configure the system to write its system journal to disk, giving you the opportunity to examine the logs of previous sessions.

To do so, edit /etc/systemd/journald.conf and changet the line #Storage=auto to Storage=persistent. Then reboot.

Thanks.

I’ll enable that later today.

Today when I got home from work the Pi had frosen again.

This time it still showed a picture, and reacted to the remote (I could navigate up/down in my movies list). As soon as I tried to navigate away from the movies list (pressing the home button), the Pi frose, and I had to reboot.

This has made me suspect that there may be something wrong with my USB stick?
It has been in continous operation for several years as my RaspBMC install, so perhaps its worn out?

Is there anyway to run a thorough check of this device?

I have changed the journald.conf as suggested, I hope it’ll give some clues…

Either from Linux using badblocks or Windows using h2testw (H2testw | heise Download)

Another question :slight_smile:

If I plug in another USB stick, is there a way to copy the current installation (mirror it) over to another disk, so that I could have a backup?
The tests would probably destroy any data on the disk…

So it would be nice to have a backup that could be plugged in, and booted from.

If you want to do a full image than you would need to make that backup from another machine. If you just want to copy/backup the data you can do that on the Pi with both sticks plugged in.

The tests can be run without destroying the data but testing the stick might stress it and that breaks it. So having a backup is recommended.

Today the Pi was dead again, but perhaps there are some clues in the logs.

May I ask which logs (and where they are placed) I should check, and what I should look for?

Best to run grab-logs -A This will ensure that all relevant information is uploaded. Please post the URL it returns.

If you want to look through the system journal yourself, run sudo journalctl

I have run the command, this is the URL:

https://paste.osmc.tv/wineqadebu

The state the Pi was in, was the same as yesterday. No picture, SSH couldn’t connect, but I could ping the Pi.

This run with the Pi was overclocked, but the crash I had yesterday was at stock clocks.

I will be happy to set Stock clocks, and reupload logs if necessary.

Hi,

ERROR: GetDirectory - Error getting

This error is repeated numerous times through out the log, I would do a reinstall. If the issue persists, try replacing the sd card.

Thanks Tom.

This part of the log is interesting:

Aug 30 15:45:53 osmc-kmv systemd[1]: Starting Sound Card.
Aug 30 15:45:53 osmc-kmv systemd[1]: Reached target Sound Card.
Aug 31 20:30:11 osmc-kmv systemd[1]: Time has been changed
Aug 31 20:30:11 osmc-kmv http-time[261]: Updated time from Wed Aug 30 13:45:52 UTC 2017 to Thu Aug 31 18:30:11 UTC 2017 using HTTP query to www.google.com
Aug 31 20:30:11 osmc-kmv systemd[1]: Started Set Time using HTTP query.

(See how the date/time jumps?) And this part is just plain crazy:

Aug 31 20:30:13 osmc-kmv bash[241]: real        1724m27.714s
Aug 31 20:30:13 osmc-kmv bash[241]: user        0m0.020s
Aug 31 20:30:13 osmc-kmv bash[241]: sys        0m0.010s

which is saying that it took over 28 hours of elapsed time to start the OSMC system.

The jump in times - and crazy startup time - are probably down to the fake-hwclock which (I think) only stores the “latest” time at system shutdown, which didn’t occur in your case. Unfortunately, if true, it suggests that there is no record of the previous system journal. I’ll need to check a few things out.