Raspberry Pi 1 512Mb unstable

So you think the error points toward a bad disk?

My install is on USB, but off course it could be the SD-card, allthough I dont think theres much activity there beyond boot?
But I have suspected the USB stick earlier in this thread.

I’m not quite certain what you are trying to say :slight_smile:

Are you saying that the logs are not written properly to disk, even though I have changed to “Storage Persistent” in journald.conf?

I’ll have to check if I made a mistake…

Will get back about it later today, when I get home from work.

It seems like the log isn’t being written to disk. Ensure that the Storage=persistent line isn’t commented out.

My own system writes its log to disk and running sudo journalctl shows the first line:

-- Logs begin at Sat 2017-08-19 12:48:53 BST, end at Fri 2017-09-01 08:26:05 BST. --

If you reboot a few times and the log is successfully being written to disk, the beginning date/time should not change.

It could be that the line is commented out still. Didn’t catch that the hashmark in front of the line had to be removed.

Sorry about that. I’ll fix it ASAP.

I have had a look into jornald and the Storage=Persistent was commented out :frowning:

Its fixed now, and the Pi is restarted.

I would like to know whats wrong with it :slight_smile:

But anyway, I have ordered a new Pi 3 from the foundation, and a PSU, SD-card and case here from OSMC, to replace this unit. Performance is not that great anyway, so time for an upgrade.

But I’ll have to live with the old Pi for probably a week or even more, and would like to have these problems fixed.

1 Like

On reflection, I’d like you to do a few more things to make the log readable:

sudo apt-get -y install cron

when cron has been installed, run

sudo crontab -e

(you’ll probably want to choose nano as your editor) then add this line to the bottom of the crontab file

* * * * * /sbin/fake-hwclock > /dev/null 2>&1

and then save (with Ctrl-X and Y to confirm, if using nano).

This will have the effect of every minute updating the fake-hwclock file with the current date/time. Without this, the system log would be more difficult to read.

One other thing. Did you confirm that the journalctl header line was showing the same date/time across reboots?

I have followed your commands, installed cron, and edited crontab. It seems Nano was allready my editor, as it opened in Nano.

I have now confirmed that logs are being written continuos. After making your latest changes I checked, did a reboot and checked again. The first line of journalctl was the same before and after reboot, showing a reboot at 16:54.

I’m quite certain logging is working now.

Now I’ll just wait for the next crash :slight_smile:

Well now all the logging and so on is set up correctly, and then the Pi doesn’t seem to want to crash…
Uptime is now nearly 3 days, before it wouldn’t last a whole day.

I wonder if somehow the fact that logging is anabled, and the clock is written to it every minut, somehow keeps the Pi allive?
Could there be some kind of sleep mode interferring?

I’ll keep it running, and we’ll se what happens.


It might be something like that but it’s just as likely to be an example of the Observer Effect. It knows you’re watching it. :wink:

Probably :slight_smile:

It hasn’t crashed yet anyway.

Well, the Pi hasn’t crashed yet. Impossible to know why it has changed behaviour.

But yesterday the new Pi3 arrived, and today the parts ordered from OSMC.
Ordered the media codec keys this afternoon and got them by mail a few hours later.

So I have it up and running now, and its scanning through my Media. This is slowly advancing :slight_smile:
Setup was easy enough as I went through all of it about 2 weeks ago on the Pi1.

There is no doubt its much faster than the old Pi, but I am still wondering if I should have made a USB install instead of to the SD-card. Time will tell how good performance is. The SD-card is the one sold and recommended from the OSMC shop.

As the plan is to replace the Pi1 with this Pi3 as soon as I finish setting it up, Its not necessary to run any more test into the original problem.

I’ll look into some job the old Pi can do, now it will no longer be my media player :slight_smile:
Perhaps it can work as my Logitech Media Server going forwards…

SD Card will be faster than USB install

Back in Raspbmc days when there were some SD problems I used a USB install but now with OSMC I only use SD. It’s plenty fast enough.

Only thing I have observed is that library scans are taking forever.
It was definately faster in my old setup.
But that of course depends on response times from the pages where the Pi collects the info, so not a real comparison.

A pi3 is vastly faster than all prior versions. In fact, I don’t have any of the codec keys and it plays all 1080p content fine. The h.264 keys have never been needed on v2 and v3 pis. The mpeg codec was necessary on a v2 Pi, but not on a v3 Pi. The CPU is fast enough. OTOH, $4 isn’t much.

I wouldn’t know how to compare either with a v1 Pi. Never had one of those. For reusing the v1 pi, I’d look at something like Pi-Hole.

The trick I use for all my osmc media players is to keep ZERO media local. All of it is on a storage server (and Plex Server) available on the network. I thought the SD cards would wear out after a year of constant, daily, use in the OSMC, but that hasn’t happened. I let plex manage all the metadata about all content and use PlexBMC as the interface from Kodi into it. I run Plex on a $50 Intel CPU, which has more than sufficient power to transcode odd media into h.264 for the Pis, as needed. Doing this provides yet another way to avoid needing an mpeg2 paid codec.

Of course, using wired ethernet is always better than wifi.

There are no H264 keys for Pi.
The cost of buying an MPEG2 license will negate the cost of powering your Intel CPU in less than one month.