Raspberry Pi 2 - OSMC Setting Service Failed to Launch

I tried to update a few days ago, the update failed, and now “My OSMC” won’t start, and there is an error when i try to upgrade again. Says “check logs” but how can i do that when i can’t enter My OSMC?

“OSMC Setting Service Failed to Launch”

Kodi-RC1 Git:Unknown (Compiled Aug 7)
OSMC 2015.08-1 (kernel: Linux 4.1.3-2-osmc)

As i see it there is only one way to solve this; clean install… but that’s sad because of all the time spent to add all the sources, etc…
I can still watch movies btw.

// Raspberry Pi newbie

As a first step I would try running updates again, most update failures can be automatically fixed by re-trying. A couple of ways to do that when you can’t use My OSMC:

  1. If you can connect a keyboard, turn on, then just after you see the OSMC splash screen appear, hold down CTRL and SHIFT together, this should initiate an update


  1. Log in with SSH, and run the following two commands:

    sudo apt-get update
    sudo apt-get -f dist-upgrade

If you get any errors with 2 please post them here.


Also, setup regular backups. It’s easy and turns disasters into minor annoyances.

1 Like

Ah, okay, i tried that CTRL+SHIFT before i wrote here. Nothing happend, it just booted straight into Kodi.
Maybe i was too fast on the keys…? Pressed them as soon as it rebooted, and released when i got to Kodi.
Gonna try again (when i can use the TV, haha)

Thanks for the fast reply’s guys!

Wait until about a second after you see the blue screen that says OSMC before you press the keys down. It should change to the blue update screen in a few seconds.

1 Like

I have backed up my OSMC but can’t figure out how to restore it. Is there a step by step for someone whom knows little about how this stuff works?

If you backed it up with the MyOSMC backup tool (found in the Updates module) then simply go to the same module and choose the Restore option from the Manual Controls page.

It takes you through all the steps.

Do you have to specify the backup/restore location first?

When you set up the backups you need to specify the backup location, and that is the first place the Restore function looks (if it is set). But the Restore function does allow you to browse for a different location (though some network shares may not be able to be navigated too, thats a Kodi restriction).

Worst case scenario, you would put the desired backup on the SD card and browse to that location.

I’m having the same update issues and can’t access my OSMC settings. Will this just be restored from a backup? I’m thinking it’s a problematic SD card that’s causing the problems.

Cant answer that as I have no idea what your problems with the Settings addon are.

It worked, i was too fast on pressing the keys before, when i waited for the blue screen before i pressed it worked like a charm =)
I’m really glad i signed up here and asked instead of a clean install that would have costed me lots of hours, haha!

Bonus question: When i go to Addons > All, i can see TONS of language-addons. Do i really need all these? Swedish and English is all i need, but is it any way to remove multiple addons fast?
Same with iStream that a friend installed for me, it’s like 50 addons just for that iStream… i want it all gone, but takes ages to manualy uninstalling them (i’m using a laggy CEC tv-remote, that sometimes registers 1 click as 2)

And thanks for the tip about backups. Gonna do these every now and then, just to be safe.

I’m having the issue of not being able to start OSMC settings on my Pi2 at home, now my B+ at work is having the same issue, though updating seems to be working fine except every day for the last two I’ve come in and had updates to perform. Maybe they’re normal updates but not being able to access the OSMC settings seems more than a coincidence. I have bought both of the SD cards from Microcenter and i’ve been reading that theres a large probability that the SD cards could be corrupt and causing the OSMC settings issue. Have you been seeing this lately? Thanks

Try running updates manually as @dbmandrake suggests above.

Multiple versions of the wifi/dvb tuner firmware package were released over the last couple of days, that would be why you have seen updates available so frequently. Nothing to worry about.

hi. i have the same problem. i get the same error when i try to open my osmc
i have tried running updates manually but after that my osmc still not opening.

Did you happen to switch to the development branch?

no. don’t even know how to do that :stuck_out_tongue:
i tried to install version 15 but that made it even worst… lost gui completely now lol
will do a fresh install. i needed one anyway