Raspberry Pi 3 fails to connect OSMC to wifi

New RPi 3 has been connecting to wifi with Raspbian (installed from NOOBS).
Installed the latest image file for OSMC and updated, upgraded over wired connection.
My wifi is listed to the right of Enable Adapter in the Network section of My OSMC.
Selecting my wifi from the list to connect takes about three minutes before the prompt to enter wifi password. Then another three minutes before displaying a message (wifi name) Failed to Connect.

I have uploaded log to

Connmanctl also fails to connect. connmanctl services wifi_…_managed_psk shows
State = failure
Strength = 91

I have read the many forum entries on this topic (now closed) but have not found a solution that has worked for me.

Could it be a power supply issue?

I have tried two different power supplies: MOKI 5.0V 2.5A + 1.0A (1.0A to power HDMI to VGA converter, 2.5A to power the Pi 3); Stontronics 5.1V 2.5A (ships with Raspberry Pi 3) with HDMI output connected to HDMI input on TV. The behaviour when OSMC (or connmanctl) attempts to connect to wifi does not change. There is a very long wait before the OSMC password dialogue displays (more than two minutes). connmanctl reports no response to the connect request, and eventually times out (i.e. agent does not request password).
The problem appears to relate to the wifi router (Audiocodes MP264) except that four android devices, and the same Pi 3 running Raspian all connect to the same wifi router using the same authentication credentials with no delay (less than three seconds).

Do you have


in your /boot/config.txt?

I think I have stumbled onto the solution (the clue being the very long wait from OSMC, and the no request for password from connmanctl connect request).
When I disable WPS in the MP264 LAN Wireless dialogue, OSMC responds to the connection request with no delay; password is accepted, and internet connection appears a few seconds later :slight_smile:

OSMC is connecting via WPA2 with password. Having WPS also enabled on the wifi router causes the OSMC (and connmanctl) connection request to fail. I do not know why it fails. Nor do I know why it does not cause failure to connect from Raspbian or Android.


I have same problem with 2017.02-2 version downloaded for Pi 3

I can connect to my iPhone Hotspot but it refuses to connect to my Airport Mini(Configured with WPA2) - “Connection to AirportMini failed”
My network is not having DHCP