Raspberry Pi 3 - Moved TV Series is no longer showing up

I have a folder that contains 26 seasons of The Simpsons.
I was running out of room on that NAS’s HDD so I moved them to a new location on the same NAS.

I’ve done this before in Kodi on Android, so I thought I would do the same on OSMC. Basically I removed the “The Simpsons” from the library (context menu, remove), then went and added the new network location and double checked to make sure I set it as “TV Shows”. The initial content refresh didn’t do anything, so I did a “Clean Up” on the library.

It recognizes the series and displays the fanart, but none of the episodes show up anymore.

They were all there before, and the format and structure didn’t change at the new location.
The only thing that changed is that the network share path is now “\\server\tv_archive” instead of “\\server\tv_shows”. (In fact, the latter still exists for other shows, just The Simpsons is not in there anymore)

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

Guh. I didn’t even think to check the logs.
And I apologize for not reading that before singing up and posting my question.
I know better.

Alright so here’s the debug log:


The lines I find suspect are the ones that say this:

WARNING: Process directory ‘smb://SERVER-PC/tv_archive/The Simpsons/’ does not exist - skipping scan.

The directory does in fact exist, and if I go browse that network location under “Files” instead of the library route, I can play the videos.

I was able to “fix” the issue by performing the following:

  • Because my NAS is technically a Windows 10 installation that is setup for the sole purpose of serving files, I had set the permissions in that shared folder to Read/Write for Everyone.
  • The above was apparently enough to have OSMC (Kodi) see the share and detect the TV Shows in the folder, but not enough to detect the episodes. I’m still not sure why not.
  • I tried a lot of things, but what finally did it was going to the actual drive that contains the shared folder and “Sharing” that drive as well. As soon as I set the share on the drive, the next Library Update on OSMC rendered the episodes visible in the library.

This isn’t really a fix in my opinion, as I don’t like to have my entire drive shared like that, but it works for now and so I’ll be leaving it this way until I have time to dig into it some more.