Raspberry Pi 3: Videos not starting


I’m using the very last OSMC version on a Raspberry Pi 3, I’ve installed it a week ago and it worked really well, but now it is unusable: when I run a video I see a strange screen with crooked lines and then It goes back to the home menu again

The kodi.log says:

(I start a video)
22:35:08 272.766266 T:1956910000  NOTICE: DVDPlayer: Opening: http://fr.vid.m.480p.acsta.net/nmedia/33/16/05/18/11/19562925_m_013.mp4
22:35:08 272.766510 T:1956910000 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
22:35:08 272.770935 T:1688204272  NOTICE: Creating InputStream
22:35:08 273.006409 T:1688204272  NOTICE: Creating Demuxer
22:35:08 273.135559 T:1688204272  NOTICE: Opening stream: 0 source: 256
22:35:08 273.145233 T:1688204272  NOTICE: Creating video codec with codec id: 28
22:35:08 273.158051 T:1688204272  NOTICE: Creating video thread
22:35:08 273.158447 T:1688204272  NOTICE: Opening stream: 1 source: 256
22:35:08 273.158600 T:1492120560  NOTICE: running thread: video_thread
22:35:08 273.158691 T:1688204272  NOTICE: Finding audio codec for: 86018
22:35:08 273.166138 T:1688204272  NOTICE: Creating audio thread
22:35:08 273.166595 T:1463747568  NOTICE: running thread: CDVDPlayerAudio::Process()
22:35:08 273.167847 T:1463747568  NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 32000, no pass-through)
22:35:08 273.168488 T:1463747568  NOTICE: CDVDPlayerAudio::OutputPacket duplicate 3 packets of duration 32
22:35:08 273.173889 T:1492120560  NOTICE:  fps: 24.000000, pwidth: 568, pheight: 320, dwidth: 568, dheight: 320
22:35:08 273.174011 T:1492120560  NOTICE: Display resolution DESKTOP : 1366x768 (1366x768) @ 60.00 - Full Screen (16)
(And then the video fail and I fall back to the home screen)

My system infos:

root@toto:~# uname -a
Linux toto 4.4.8-3-osmc #1 SMP PREEMPT Sun May 1 18:57:43 UTC 2016 armv7l GNU/Linux
root@toto:~# kodi -v
16.1 Media Center Kodi
Copyright (C) 2005-2013 Team Kodi - http://kodi.tv

Installed from OSMC_TGT_rbp2_20160502.img

Any idea?
(apt-get update/upgrade/dist upgrade does nothing, everything is up to date)

Note: my RPI3 is on 5V/1A power supply, not sure if this really matter?

Best regards

1A is very low for a rpi 3.
Recommended are 2.5A

Is this happening with every video? Or only with this web stream? Does enabling omxplayer help?

Actually, I figured out that when I was tweaking the audio I enabled a DSP, which was apparently causing the problem. Disabling it is now OK (maybe this is also because this cause power consumption?)